Compiling with assimp


#1

well, I need to load .obj or .fbx 3d models, these models can’t be converted using another software like blender or maya, because the project’s workflow is way too big, so i can’t make it bigger.

i’ve tried using the native converter and the TreeForce one, but none of those work for me (no textures), so I read I can load those formats using panda+assimp, but i cant figure out how to compile them together.

i’ve compiled panda3d using the git source code and the w7 SDK (it gave me a .exe to install panda3d 1.10), also i’ve compiled the assimp using cmake, it gave me a VS project, but i dont know what to do next, can you guys help me? im kind of new on visual (i’ve used mostly Unity).

i think i have to drop the assimp into the panda3d thirdparty folder, but i dont know exactly what to drop there: assimp compiled (VS project)? assimp source code? assimp binary (downloaded form website)? maybe something else?

i hope you can help me out, thanks a lot for your attention.


#2

The libraries (compiled for MSVC 2010, in your case) should go into the thirdparty/win-libs-vc10-x64/assimp/lib directory, and the header files should go into the …/assimp/include directory.

You can use CMake to generate a VS 2010 solution which you should compile in Release mode to generate the required library. If a VS 2010 solution is supplied, you can use that.

If you wish to build Panda using VS 2015 instead, the precompiled thirdparty packages for VC 2015 that can be downloaded here do include assimp, I believe:

Once you’ve compiled Panda with assimp support, you can set “load-file-type p3assimp” in your Config.prc to enable it.


#3

i cant compile using your thirdparty package, it get stuck at 24% when building p3display_composite2.obj, any idea what could be wrong? can you compile it (i just really need assimp) and upload the .exe for me?


#4

As of today, the Python 3.5 and 3.6 builds produced by the buildbot are compiled with VS 2015 and include assimp:

panda3d.org/download.php?pl … =devel&sdk

Be sure to grab a build for Python 3.5 or 3.6, since the regular Python 2.7 build does not include assimp support at this time.

Let me know if you run into any issues.


#5

i downloaded the f7af155e93d549a43382210f41d14b9068a74a59 version but, when i add on the config.prc the line “load-file-type p3assimp” console shows “Unable to load libp3assimp.dll : Unknown error 1114”.

what am i doing wrong?


#6

I tracked down the issue to a bug in Assimp. I’ve made a fix and made my own build of assimp. Please try the latest devel build of Panda for Python 3.


#7

nope,i dont know if i downloaded the right build, i tried with the thirdparty folder found here Building Panda3D with MSVC 2015 and Python 3.5/3.6 , but i still having the same problem


#8

Give this build a try:
buildbot.panda3d.org/downloads/a … .6-x64.exe

If you are building from source make sure you have used --clean or deleted the “built_x64” directory beforehand.