Compiling on Kubuntu 12.04


Well, I got Panda source code (v1.7.2) but when I try:

./makepanda/ --everything

it gives me the messages:

There is no “thirdparty” folder in this source code, neither for download (v1.7.2).

What should I do?
I’ve also tried

./makepanda/ --installer --everything --no-fftw --threads 2

(I have a dual core cpu)
but it gives me the same results. :frowning:

Actually, I can find the thirdparties for download, but for another version (1.3.x).

I’ve also already tried to manually install these thirdparty, unsuccessfully.

I’m lost, please, help me. :frowning:

You have to install the relevant packages (the one you are interested in) using your package manager, like libssl-dev, zlib1g-dev, python-dev, libjpeg-dev, libpng-dev, nvidia-cg-toolkit…


I did a test with “jpeg”.
I used

sudo apt-get install libjpeg-dev

… It installed (once was not installed, of course).

Then tried “makepanda” again, and the line

is still appearing. That is because it looks for the thirdparty packages from the folder, instead of the ones installed in your system, I suppose.

Even in the “makepanda” readme file, it says you must have the thirdparty folder:

If you download the source version 1.7.2, you will see the “Makefile” and the “thirdparty” are missing.

Well. I got them from the complete source v1.6.2 (the last which you find those missing ones).
I’ll test here and watch the results then give you a feedback.

Hope it works :exclamation:

There is no “thirdparty” directory for Linux. You have to install them on your system, as I said. It looks for the packages on your system. I do not advise trying to use an outdated thirdparty directory.

As for jpeg, perhaps the package name is libjpeg62-dev?

Well, I got the thirdparty folder from an older version as I said, and the lines warning me about each missing one were less.
I cannot post them now because my system crashed.

I`ll test it today. Let me just finish resetting up the system.


Sincerely, I DESIST from “makepanda”!

Really, you must get manually EACH thirdparty package for it!

Just to get jpeg lib, I had to find its website, find the source, download, extract, compile and FINALLY install it. Because using my built-in package manager doesn’t solve it (not even through bash).

Sorry to say, but I’m very said about it. Not because I’m newbie to the Panda3D… But because it doesn’t provide a complete installer since it asks you for those “missing” libraries just to fully work.

If I’m wrong (what I actually really wish) tell me, please, and explain me why I cannot simply build and install it.

Please, I need to get it running so I can learn it, for a commercial project.

I would be really thank!
And soon, I’ll make sure I’m going to deploy a true automated builder|installer.


Check the thread just below this one for a complete Ubuntu 12.04 package :slight_smile:

[Panda for Ubuntu 12.04)

It’s really just a matter of installing the right packages. There is no need to compile jpeg from scratch, and doing so could actually interfere with the proper working of your system.

Since you are building an outdated version of Panda, it may be that it had an older version of makepanda that was not yet able to pick up the newer ubuntu jpeg package correctly.

Ok. Thank you all for the help.
And, of course, sorry for my “upset behavior”.
That’s because I crashed my system (As rdb said above, just by trying to compile them from scratch).

Actually I migrated to Fedora distro (I’m not sorry for that, fortunately).

Anyway, the 1.7.2 version does not provide me the RPM package, so, whatever… I’ll have to hunt these thirdparty libraries anyway. LOL

But this time I’ll be careful.

As the topic is about Kubuntu 12.04, and now I’m no longer using it, I think I may say I’m done here. :slight_smile:

But anyway, I’ll give you a feedback soon, right here, just for you to know what I had to do to get it working. :stuck_out_tongue:


I am trying to compile panda3d for(on) the raspberry pi. I have been using it on ubuntu on a laptop for a short while and am impressed (easy to install works very well).

However on the raspberry pi I get these same thirdparty package warnings. I am compiling with --nothing --use-png --use-jpeg --use-python

when I got the warning I tried sudo apt-get install jpeg
etc which seemed to install ok though for python it told me that I already had the latest version. gives the same warnings.

I then noticed that you (rdb) suggested that jpeg implies the installation of libjpeg62-dev or suchlike!!!

The link does not seem obvious to me and I can’t find any information in the documents or online.

Could you point me in the right direction? Maybe something in the INSTALL-MK would be a good idea. It says you don’t really need the thirdparty things for linux but that otherwise download the thirdparty stuff (which I thought might have some clues to help match jpeg=libjpeg62-dec etc) from “Panda3D source, piecewise, 3 of 3” however this doesn’t seem to match anything on the panda website any more.


You’d need to install the -dev packages, such as python-dev. Some packages (like libmesa-gles1-dev) are a bit trickier to figure out, but still easy by running makepanda with the --verbose flag and checking which files are missing, and then using “apt-file” to find which package has that file.