compiling maya2egg2008 on windows


compiling panda with the makepanda.bat works fine, except that i cant get the maya converts to compile, and i would like to use the egg tags with maya.

first problem: in my maya sdk isnt found (i think theres a bug somewhere in the SdkLocateMaya() function). so i just pass the path to maya manually there like this:

SDK["MAYA2008"] = "D:\Program Files\Autodesk\Maya2008"

then it seems to be found, but when it comes to linking the mayaeggimport2008.mll he wants some obscure Program.obj and cant find it.
i have absolutely no idea what this could be.

here goes the complete error part:

link /nologo /NOD:MFC80.LIB /NOD:LIBCI.LIB /NOD:MSVCRTD.LIB /DEBUG  /nod:libc /nod:libcmtd /nod:atlthunk /DLL /MAP:NUL  /FIXED:NO /OPT:REF /STACK:4194304 /INCREMENTAL:NO  /OUT:built/plugins/mayaeggimport2008.mll /LIBPATH:"thirdparty/win-python/libs" built/tmp/mayaegg2008_loader.obj built/tmp/mayaeggimport2008_mayaeggimport.obj built/lib/libpandaegg.lib built/lib/libpanda.lib built/lib/libpandaexpress.lib built/lib/libp3dtool.lib built/lib/libp3dtoolconfig.lib built/lib/libp3pystub.lib advapi32.lib D:\Program Files\Autodesk\Maya2008/lib/Foundation.lib D:\Program Files\Autodesk\Maya2008/lib/OpenMaya.lib D:\Program Files\Autodesk\Maya2008/lib/OpenMayaAnim.lib D:\Program Files\Autodesk\Maya2008/lib/OpenMayaUI.lib
LINK : fatal error LNK1181: cannot open input file 'D:\Program.obj'

im using vista and vs 2005

thanks for help!

Naw, the problem is the space in “Program Files”. See this parameter on the link line?

D:\Program Files\Autodesk\Maya2008/lib/Foundation.lib

This looks to the linker like a reference to “D:\Program”, followed by a reference to “Files\Autodesk\Maya2008/lib/Foundation.lib”. It barfs on the non-existent D:\Program, of course.

The solution is to put quotes around the parameter on the command line. Not entirely sure how to achieve that in makepanda, but you could try:

SDK["MAYA2008"] = '"D:\Program Files\Autodesk\Maya2008"' 

Or, failing that, use the alternate name for D:\Program Files, using Window’s obscure 8.3 naming convention:

SDK["MAYA2008"] = "D:\Progra~1\Autodesk\Maya2008" 


i think there is a mistake in “”.
changing the last line of code in function SdkLocateMaya(), line 673 from

SDK[res] = ver


SDK[ver] = res

worked for me

man you are so fffast!! :slight_smile:

neither of these versions worked. i had to copy the relevant folders to a directory without spaces in its name. ouch.

thanks alot!