Compiling 1.7.2 on Windows

Firsly, I used the files … 7.2.tar.gz
and …
(which by the way is not mentioned on the main download page)

The icon file seems broken.
So, I replaced the icon panda/src/configfiles/pandaIcon.ico with some other random icon from my machine.

Then I get this error:

If I build with --no-ffmpeg --no-swscale it works fine. But I would like to use ffmpeg.
Is it related to the use of int64_t maybe?

Otherwise is there some way to disable Interrogate? As I’m using C++ anyway.

Edit panda/src/movies/ffmpegVirtualFile.cxx, and replace int64_t with __int64. Then it should compile.

You could also compile with --no-python.

Thanks, the __int64 fix worked.

However, I also tried using the --no-python option I got this:

It seems ssize_t is defined in pyconfig.h? Is there another/better place for this?

Do you think the --no-python will make the Panda3d library smaller, and/or faster for C++ use?
If not, I won’t worry about it.

ssize_t should be defined in stddef.h, which is included by stdlib.h.

Compiling with --no-python will definitely be beneficial for you. Panda will be much smaller, and you won’t need to link with the Python library.

I can’t seem to fine ssize_t defined anywhere on Windows.

I tried
#include <stdlib.h>
#include <stddef.h>
and a bunch of others with no luck.

So I just put this at the top of openCVTexture.h which does the trick.

#ifndef HAVE_SSIZE_T
#ifdef MS_WIN64
typedef __int64 ssize_t;
typedef _W64 int ssize_t;
#define HAVE_SSIZE_T 1