compiling 1.7.0, windows

I read this manual page: … on_Windows

I get this:

it isnt mentioned in the manual page.
I never heard of such download…

Get it from the download page.

i cant find it

Click “Download”, “SDK”, and then “Windows”. Then you end up on this page: … =1.7.0&sdk

Oh, the “full” version for win32? But theres also a 30mb source. what is the reason to have 2 versions of the source?

One includes the thirdparty packages, the other doesn’t. There’s also an archive with the thirdparty packages alone.

I got the one with the thirdparty folder. I see the folder and its content, but I still get the same error. :confused:

Should I redownload everything again and retry?

Did you install the thirdparty folder inside the panda3d folder, alongside the makepanda folder?


Yes I did.
I just removed everything and did all the steps over again. Same error.
Using windows 7.

Are you sure? Panda3D detects the thirdparty directory inside the source root, so you should have the directory panda3d/thirdparty alongside panda3d/makepanda.

And are you sure you are also invoking makepanda properly? You should invoke it from the source root, like:

makepanda/makepanda.bat --everything --installer --lzma

I then do

cd desktop\panda3d-1.7.0

According to the Manual this brings up all the command options for makepanda.bat

But I get that error message instead.

Maybe makepanda.bat has an error?:

@echo off

REM Verify that we can find the 'makepanda' python script
REM and the python interpreter.  If we can find both, then
REM run 'makepanda'.

if not exist makepanda\ goto :missing1

if not exist thirdparty\win-python\python.exe goto :missing2
thirdparty\win-python\python.exe makepanda\ %*
if errorlevel 1 if x%1 == x--slavebuild exit 1
goto done

if not exist thirdparty\win-python-x64\python.exe goto :missing2
thirdparty\win-python-x64\python.exe makepanda\ %*
if errorlevel 1 if x%1 == x--slavebuild exit 1
goto done

  echo You need to change directory to the root of the panda source tree
  echo before invoking makepanda.  For further install instructions, read 
  echo the installation instructions in the file doc/INSTALL-MK.
  goto done

  echo You seem to be missing the 'thirdparty' directory.  You probably checked
  echo the source code out from sourceforge.  The sourceforge repository is
  echo missing the 'thirdparty' directory.  You will need to supplement the
  echo code by downloading the 'thirdparty' directory from
  goto done


No, it looks right. Perhaps you downloaded the wrong thirdparty packages? Or maybe you’re trying to compile Panda3D on a 64-bits system?

Thats a good guess. I can’t? :frowning:

At the moment, we don’t support it.


That is disappointing…

Well, I found an old pc.
Can you tell me if there are any plans in adding 64bit support? Is it because of Visual Studio?

Anyway, I get this now:

You have to run it from the Visual Studio 2008 Command Prompt.

Ok, but they manual explicitly tells you to open the Command Prompt with START->RUN and type cmd. Isn’t it wrong then?

EDIT: Still getting the same error…

Panda will absolutely build correctly on 64 bit systems; I’ve done it on three of them (one of them being Xp 64bit). I think what rdb means is that you can’t build a 64 bit version of the dlls and stuff. I wouldn’t worry about a 64 bit version of your program unless you plan on manipulating a 2gig+ memory block.

Getting panda to build at all is a major pain in the neck, and one of the first things that needs to be done is modify the makepanda.bat by adding this line to the top:


Do that, and you should be able to build it as:
cd panda3dfolder
makepanda\makepanda --everything --optimize 4