collision detection


I just started using Panda3d. I’ve been having a problem with the roaming ralph program. I just replaced the world.egg with a different .egg file. I have not modified the source code otherwise. But collision detection no longer works. Can someone please help me and let me know what could be wrong?

Unforntunately , Roaming Ralph collision detection sample use the name of the model to detect the collision with the terrain.
So if in your scenegraph the land is not called “terrain” then no collision detection will occur.

The name is taken from your .egg so from your modelling package.

Another option is tor replace all code lines “().getName() == “terrain”):”
by "().getName() == “YOURTERRAINNODENAME”):

but this is short term options to understand the principle.

Personnally i would use some tag on my models to declare them as TERRAIN and i won’t check the name of the node but the tag he have.

Thank you! But i have changed the name in the .egg file to terrain and it still doesnt work. Is there something else that I could be missing out on?

Can you check what is returned by “shift-l” when you load the model in pview?

is there a “terrain” name somewhere in the hierarchy?