Collada file exported from sketchup invisible in pview

Hi guys,

I tried some other things but… The model doesn’t seem to have any errors in sketchup. So it can be only that the collada file is “optimized” for google earth by default, or there is some kind of weird error in there…

So, here’s the file. Some quick terrain, but it’s invisible:

Exported to .X(3DRad plug-in) and then x2egged. Worked perfectly.

small text
Did someone else find out that x2egg is the most reliable converter in panda? :slight_smile:

That’s because Sketchup exports the models to .dae with inverted transparency. You need to manually invert the transparency in the .dae file before converting to Panda3D.

Wait how do I do that? Dae used to be an archive but now I can’t open it. So I must do it blender or something? Or can it do Panda3D on it’s own?

You can open the .dae file with a text editor, it’s an XML file.

So from what I read, there are 2 modes of transparency in the collada format. A_ONE and RGB_ZERO. A_ONE has 1.0 as fully opaque, and RGB_ZERO as fully transparent.

Ok, so I have to change some 1’s to 0’s. And I tried to find it, and the only thing that partly reminds me that is this:

0.48 0.48 0.48 1

So I changed it to 0 and nothing. The same. So can you help me? Thx in advance :wink:

Also this didn’t help me to:

Right, try replacing RGB_ZERO with A_ONE instead of changing the values.

As I said, didn’t work!

Can you upload the model somewhere?

–Yes it’s in the first post–

ok I created a new model and somehow it worked immedately. Maybe it can’t display so called “components” and “groups”? Or the model has some kind of error that panda can’t display? huh… I’m so tired =/

Hi guys,

It is true that SketchUp used to export COLLADA with inverted transparency settings, but this has been fixed in the latest release. SketchUp 7.1 (which can be downloaded for free from has an entirely rewritten COLLADA importer and exporter that fixes this and many other issues.

Hope this helps-

Oh, thanks for the heads up!