Chicken single file export not working with pview

Chicken R76b

I’m unable to view any animations in pview when I export using the single file option. No errors are raised in chicken, but when pview loads it says that there is no animation present, even though animation data appears to be in the generated egg file.

i can confirm the issue. loading one of the egg’s in pview even hard-crashed my linuxbox (not reproduceable thing).

It shouldn’t cause a crash - not sure what happened there, but yes, it doesn’t work. pview simply doesn’t support single file egg’s - the convention in panda has always been for multiple files. I on the other hand prefer single file eggs, as they are easier to work with, hence Chickens preference for them - it is a bit of a miss match I know, but when writing your own code the files work fine.

pview doesn’t? Can someone send me an .egg file with animations then, so I can try and reproduce the problem?

Last time I tried, it worked for me (although that was a .dae file)

You could just export the export-char-simple-test.blend file from the chicken tests folder - that exhibits this problem as well as any other file. If your looking into this you might want to consider that right now pview only does one animation at a time, as far as I can tell - would be nice if you could toggle through them, as a single file can contain many animations.

pview certainly does support single-file anim and model .egg files; for instance, ripple.egg that ships with panda is one such file. And no egg file should ever crash Panda just for loading it; if it does, that’s a bug in Panda.

It’s true that there’s no interface in pview for switching between multiple animations, though there are other animation controls that show up with you use pview -a .