Can't pack nor deploy

This is weird.
I try to use pdeploy (or packp3d) and nothing happens. No error, no warring, no feedback, no nothing, even ‘pdeploy -h’ does nothing. I also tried pdeploy.p3d and pdeploy.exe.

It’s the first time I try to build a .p3d with 1.8 on this machine (win xp) as far as I remember, but it worked with 1.7.2.


Do you have Panda runtime installed?

Yes, I’ve reinstaled it 3 times, but I think the runtime is the problem, p3d files just won’t run.

An update:

The packp3d/deploy tools worked ok on a windows vista laptop, both the p3d and exe worked( more or less, openGL fails on that system, but dx9 works, not a panda thing).

The p3d and exe generated on the vista laptop do not work on my windows xp machine.

An old exe, generated with 1.7.2 works.

My PC is ancient. It has a Athlon XP cpu with no SSE2 support, but can that be a problem again?

I’m really, really lost here, and I can’t go back to 1.7.2.

Ah, sorry, the Windows runtime build on 1.8.0 is built with SSE2 enabled by default. I’ve disabled it in the buildbot script, the upcoming 1.8.1 release will see it fixed.

Ok, thanks. That’s good news and bad news.
The buildbot version dosen’t have packp3d and pdeploy, right? So I’ll need to wait for the official 1.8.1 release?

Right, sorry. There are packp3d_dev etc, but you should never distribute the .p3d files that you create using it, you can only use it for testing.