Can't make the Tutorials work!

Hi Folks,

After getting the first tutorial up and running (a Panda model walking across a grassy scene) I’ve hit a snag.

No matter what I try, I can’t get the Basic Tutorials to work for me. I write my script EXACTLY the same way that the tutorial says to, but it simply won’t run. I get lots of error messages.

I tried to load and run the existing ‘ script’ in the sample directory, but it too would not run and gave me the very same error messages.

Yet when I double click the shortcuts they work fine. This is all very frustrating, and I see from other posts that I’m not the only one with this problem. Any ideas?


Can you show us the error messages you are getting?



Could you please tell me how to ‘copy and paste’ something from the Command Prompt Window?

Also, while your at it, could you tell me how to change the path. At the moment my Command Prompt Window (from the Start>Run>cmd) points to C:\Documents and Settings\ and it won’t let me change it. I’ve tried deleting it and backspacing it out.

Sorry, I’m a complete and utter noob :blush: and I’ve never used a command prompt before.



  1. to open cmd prompt where i want , i’ve add an entry in the context menu that appears when u right click on a folder.
    This entry open a prompt in the directory you selected before doing the right click.

In Window you can do this with this registry settings
Windows Registry Editor Version 5.00
@=“Command &Prompt Here”
@="C:\WINNT\System32\cmd.exe /k cd “%1"”
(copy paste in a .reg file and merge it with registry)
(i recommend registry backup before any operation in registry)

  1. to copy paste in command prompt, you select the content with the mouse and you right clik
    first right click =copy , second right click= paste
    (if this not work change the quick edit settings of your cmd window,but default settings is ok )to copy from outside the cmd window ,ctrl+C then right click in the cmd window to paste.

Thanks a lot for that reply, that worked nicely. I’m a bit scared to muck around with my computer settings though, so I’ll leave them as they are. It just means that I have to save all my .py scripts in the C:\Documents and Settings directory, or in this case, copy and paste the tutorial .py’s into it.

Anyway, these are the errors I get when I try to run the tutorial. When I hit ENTER, it says that it is starting the game and the Panda window (with a black background) pops up for a second or two. But then it quickly closes and this is displayed on the command prompt window:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Kathy&Jill>ppython

DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(3 aux display modules not yet loaded.)
:loader(error): Couldn’t load file models/solar_sky_sphere: not found on model p
ath (which is currently: “.;/c/Panda3D-1.0.3/etc/…;/c/Panda3D-1.0.3/etc/…/mode
:gobj(error): Texture::read() - couldn’t read: models/stars_1k_tex.jpg
:gobj(error): Unable to read texture “models/stars_1k_tex.jpg” (using vfs) on t
exture_path .;/c/Panda3D-1.0.3/etc/…;/c/Panda3D-1.0.3/etc/…/models or model_pa
th .;/c/Panda3D-1.0.3/etc/…;/c/Panda3D-1.0.3/etc/…/models
Traceback (most recent call last):
File “”, line 166, in ?
w = World()
File “”, line 40, in init
self.loadPlanets() #Load and position the models
File “”, line 65, in loadPlanets, 1)
AttributeError: ‘NoneType’ object has no attribute ‘setTexture’

There you go, hope it makes sense to you :unamused: .


HAHA I’m such a genius :wink: ! I’ve figured it out by myself!

It’s marvelous what you can do when you try. And I was determined it wasn’t going to beat me.

Anyway, I went back over the first tutorial (the one that worked) and re-examined, line by line, the Solar System error messages posted above.

It seemed to me, that the problems started when the interpreter tried to load the Solar System models. For some reason it just couldn’t find them.

Yet the first tutorial worked perfectly. So I went into the main Panda3D model directory, and sure enough, the models weren’t there. For some odd reason, they’re installed in a folder named ‘samples’.

So all I did was copy all the files (13 in total) from the first tutorials ‘model’ folder to the main ‘models’ folder and… Viola!!! When I run the Solar System .py file again, it works!!!

I guess I’ll now have to do this for all the tutorials. Ah well, it’s easy enough to do.

I figured I’d post my solution here for anybody else who’s having trouble with the tutorials. Hope it works for you too.


PS. I was playing around with the, because it too is in the ‘samples’ folder and wouldn’t run when I tried it in the command prompt. I did the same thing with it, copied its model files into the main ‘models’ folder, and it worked a treat, except there wasn’t any sound.

So I checked the main directory, and discovered that there wasn’t any sound folder, so I’ve created one and copied the GreetingCard .mp3 into it. Everything now works perfectly :laughing: :laughing: !!! I’m very happy!!!

Just thought you’d like to know.

Hi Witchetty,
Actually, the solution to your problem is much simpler than you have made it. All of the tutorials were made to look for the models relative to the code file. So if the tutorial is run in “C:\Documents and Settings\Kathy&Jill”, then it will look for the models in “C:\Documents and Settings\Kathy&Jill\models”.

What it looks like you have done is to copy to your home folder (which is where DOS prompts open by default) without copying the rest of the directory. So putting everything in MODEL_ROOT ("\models" by default) fixed the problem. However, all you really need to do is to get a command window to the tutorial’s original directory, and do:
C:\Panda3D-1.0.3\samples(tutorial dir)> ppython
and it should work fine.
(Sorry, I don’t actually have a panda installation in front of me right now so I don’t remember exactly what directory that tutorial is in)

The shortcuts in your start menu are examples of starting the programs in their proper directories. Right click one and select “properties” to see the details.

As an aside, when you make a project you should put your art assets somewhere into folder relative to the code like we have done with the tutorials. Putting everything into MODEL_ROOT means that the models are accessible to every project, meaning that you can’t have two different things named the same, which could cause headaches if you are working on more than one project. Besides, it will make it harder to figure out which assets go with which project when you want to distribute something.

Thanks a lot for your reply Augur.

“However, all you really need to do is to get a command window to the tutorial’s original directory, and do:
C:\Panda3D-1.0.3\samples(tutorial dir)> ppython
and it should work fine.”

This is where I’m having all the trouble, I don’t know how to make the command prompt window point to C:\Panda3D-1.0.3. And I’m simply too inexperienced to muck around with my computer settings.

I’m really stumped here. So for now, unless somebody knows an easy way to make the command prompt window point to where I want it to, I’ll leave it setup as it is. At least it’s working :smiley:.


You need the “CD” command:

cd \panda3d-1.0.3\samples\somethingorother

From the command window start by typing "cd " and press enter
Then type the first part of the directory name, panda in this case, and then press tab. It should complete the directory for you. If it choose another directory (one that happens to also start with panda), keep pressing tab until you get the right directory. Then press enter.
Repeat the last step with each subdirectory until you get to the one you want.

Finally, when you are in the correct directory, yse the ppython command as you had before.

Of course, the other remedy would be to copy the entire directory for a given sample, not just the .py file to an easier directory to access.

Hiya, it’s me again. You guys are terrific! Thankyou so much for your patience.

At last, the problem seems to be solved (fingers crossed :laughing: ). From what you’re all telling me, I gather that I should just ignore whatever is written on the command prompt window, and just type cd\ after the > symbol.

Well, I’ve done that, and I’m here to tell you that it works perfectly :smiley:. Thankyou! Thankyou! Thankyou!.

One small thing though, in the ‘Introduction’ Tutorial, it tells you to type:

cd C:\Panda3D-1.0.2\Tutorials\Part 1-Solar System(scene graph)\

This appears to be wrong (and apart from the obvious version number change) because there isn’t a Tutorials directory. I guess it’s been changed since version 1.0.2.

Anyway, to get the tutorial .py’s to run, you should now type (after the > symbol):

cd C:\Panda3D-1.0.4\samples\Basic-Tutorials–Lesson-1-Scene-Graph\

Hit ENTER, then type:

ppython (or whatever the name of the .py file you wish to run is) then press ENTER again.

Hope this is of help to somebody :unamused: