Can't Get Mesh to Export Properly

Hello everyone. I’m trying to export a simple model from Blender. The model is a pyramid and it has an armature with 2 bones so it can be bent back and forth. I also have a single animation called “Wiggle”. It works properly in Blender, but when I tried to export it as an x file and convert it to an egg file, the animations weren’t exported even though I checked the boxes for exporting the armature, rest pose, and animations. I also tried exporting with blend2bam, but then it loses the texture somehow even though the animations get exported. Any ideas how to fix it?

About the format .X this has not been stable recently. I’ve reported this issue:

I’m using Blender 2.79 and I exported with these options:

X Export Options:
[x] Export Selected Objects Only
Coordinate System: [Left-Handed]
Up Axis: [Y]
[x] Export Meshes
[x] Export Normals
[ ] Flip Normals
[x] Export UV Coordinates
[x] Export Materials
[ ] Reference Active Images as Textures
[ ] Export Vertex Colors
[ ] Export Skin Weights
[ ] Apply Modifiers
[x] Export Armature Bones
[x] Export Rest Position
[x] Export Animations
[x] Include Frame Rate
[x] Export Actions as AnimationSets
[x] Attach Unused Actions to First Armature
[ ] Verbose

Blend2Bam Command Line:
blend2bam Pyramid.blend Pyramid/Pyramid.bam --textures copy

I think you should provide a BAM test file with the texture.

Alright, I’ll upload it and post the link. I can supply the blend file too if you need it.

I included the blend, bam, and texture files in this zip:

If you’re using Blender 2.79, you could also try YABEE; it has its own caveats, but I’ve found it to work well, with Blender 2.78 at least.

(The main caveats that I recall offhand being:

  1. Textures should be applied via materials–just setting them in the UV-editor won’t work
  2. And animations are specified either as start- and end- frames or as actions in the action-editor.

Here’s the main thread for YABEE, which should include a link to a site from which it can be downloaded:

Looking at the search result for all textures, we can say that this texture is not in the model.

from direct.showbase.ShowBase import ShowBase

class MyApp(ShowBase):

    def __init__(self):

        self.scene = self.loader.loadModel("Pyramid.bam")
        print (self.scene.findAllTextures())

app = MyApp()

I tried exporting with YABEE and it worked properly. Thanks for your help. :slight_smile:

1 Like

I’m glad that it worked for you! :slight_smile:

Do be aware that, should you switch to Blender 2.8, the version of YABEE linked-to above doesn’t work with that version of Blender. There was a modified version that did work with it, but I don’t know the status of that offhand, and its feature-set wasn’t quite the same.

That said, I think that there are other export tools that do work with Blender 2.8.

I probably won’t switch, because Blender 2.8 had terrible performance on my PC. Not sure why though. It’s the newest version of Lubuntu and it’s 64-bit. Probably the video card is old I guess.

That’s fair; I just felt it worth mentioning the issue, in case it came to affect you. :slight_smile:

I appreciate it. Thanks. :slight_smile: