Can't find NodePath class in Panda3D Python reference

when loading a model with Panda3D, I use some statements like:

self.environ = self.loader.loadModel("models/environment")

The method “loadModel” will return an instance of NodePath class.
However, I can not find NodePath class in Panda3D’s Python reference.
Instead, I can find NodePath class in Panda3D’s C++ reference.
Am I wrong with searching NodePath in Panda3D’s Python reference?
Or there is no this class doc in Python reference indeed, and only in C++ reference?

Where have you searched? I can find it where expected.

I can find NodePath class in Panda3D’s online Python reference, but I can not find it in the downloaded python reference.
There is no panda3d package doc in the downloaded version.
May others can confirm this problem?

Ah ok, I was assuming you were talking about the online reference, I’m sorry. There were some problems about the reference when 1.7.2 has been released, maybe this is related.

Yes, it described the same problem.
However, it is strange that the topic said that the problem was solved, but when I using the downloaded python reference version, the problem still existed.
Maybe only the online version was corrected, and I hope Panda3D 1.8.0 Python reference does not has this bug.

I think the problem has been solved after 1.7.2 was released, so the packaged version didn’t contain the corrected reference (it’s only a conjecture). The bug has been fixed, so there should not be reasons to see it again. Anyway, you can check that analyzing the ‘devel’ version of the reference here.