Can't compile on VS2017


#1

I can’t compile any project using VS2017 if using Windows 7.1 SDK, it gives me this error:

1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\Microsoft.Cpp.Win32.Targets(57,5): error : Required file “” is missing.

I tried searching all over the internet and the only solution found is installing VS2010, but the main tutorial of panda3d don’t uses this version of VS, so I suppose there is another solution?
Please help.


#2

Which version of Panda3D are you using? Did you grab 1.9.4 or a development build?

Either way, it may be worth trying to grab a recent development build of Panda3D, since the development builds are built against the v140_xp toolset, which may be more accessible/reliable than the Windows7.1SDK toolset.


#3

Thanks for your reply!
I forgot to say that I need to get 1.9.4 working here, no other choice.


#4

That’s unfortunate.

Are there any more error messages given? The error message by itself doesn’t really say much.

It might be worth making sure you have indeed installed the Windows 7.1 SDK. There might be additional updates of import as well, like this one.


#6

I made sure the Win 7.1 SDK is installed (made a full repair of installation) and installed this update as well, still doesn’t work…

I followed every step of this guide here

The only error i get is this one, when trying to build an empty project, as stated on the guide.

1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\Microsoft.Cpp.x64.Targets(63,5): error : Required file “” is missing.

It fails and doesn’t compile.


#7

Could you post a zip archive containing your project so that we can try and see if we also get the same error?

By the way, when I Google the error, I do get suggestions on instalilng the Visual C++ 2010 Redistributable. I do suggest trying this if you have not already; the Redistributable is a small download containing runtime libraries and does not contain the VC++ 2010 compilers or IDE.


#8

Project here

notice it has nothing in it, it’s just the project that should be able to build after this guide

And I already had VC++ Redistributable 2010, reinstalled it just in case but still nothing good.


#9

The project has no source files added to it? That might explain the error message. Perhaps the guide is not clear about it, but you should try adding the source file from the Hello World tutorial.


#10

I’m sorry, I don’t understand. Could you be more specific?


#11

Sorry, I had misunderstood something you said.

I finally managed to install the Windows 7.1 SDK, and I then also installed the VC++ 2010 Compiler Update and the VC++ 2010 Redistributable for good measure.

Then I opened your solution and built it. To be able to build it I had to add the C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE directory to my Path (in my system environment variable settings, not in VS) and reboot, and I also had to change the “Include Directories” and “Library Directories” settings in the “VC++ Directories” tab in the project settings to tick the “Inherit from parent or project defaults” checkbox in the “Edit” dialog (not the same-named option in the dropdown).

Then, it built and ran just fine. If after all these steps you cannot build the project, it must be some problem with your compiler, Windows SDK or Visual Studio set-up.

I do really recommend you use a development build of Panda3D, by the way. You no longer need to use the ancient Windows 7.1 SDK with that. You can still target Windows XP if needed by selecting the v14*_xp toolsets.