Cannot locate MAYA85

Hi, all.

Trying to convert from .mb to .egg.

D:\05_06_08>maya2egg85 -a model -o car.egg CAR_v11.mb
Cannot locate MAYA85 - it does not appear to be installed


Maya 8.5 (legit commercial version with Complete and Unlimited licensing) is installed, although not at the default path.

Is there somewhere to configure where maya2egg looks for the Maya install?

It uses the windows registry to find Maya 8.5. The following registry key is supposed to exist after installation:


On my machine, the value of this registry key is c:\Maya85

Do you have this registry key? If not, could you look for something similar? I wonder if I’ve missed something.

Hmm, okay. I have Maya 8.5, and Maya 2008 on this machine.

I had a registry key at that location for for Maya 2008, but not for 8.5.

So, I created the appropriate key, and put the correct value in there. Now I get a different error:

D:\05_06_08>maya2egg85 -a model -o car.egg CAR_v11.mb
Could not launch C:\Panda3D-1.5.1\bin\maya2egg85-wrapped.exe


That is a valid path to the maya2egg85-wrapped.exe.

Also tried using 2008 and got the same thing:

D:\05_06_08>maya2egg2008 -a model -o car.egg CAR_v11.mb
Could not launch C:\Panda3D-1.5.1\bin\maya2egg2008-wrapped.exe


The source for that maya2eggs85.exe is available, yes? Perhaps I’ll peruse that. Not sure why this is such a problem. Does the thing rely on any environment variables? We are heavily customized here.

P.S. I’m running 64-bit Windows and 64-bit Maya(s).

Upgraded to Panda 1.5.2. Same issues.

It’s the 64-bit maya that’s the problem. The exporter is compiled for 32-bit maya.

This is getting to be a real problem: too many versions. I’m already compiling for a half-dozen versions of maya. Each time I want to add support for another version I have to beg somebody to loan me a copy. Now there are 64-bit versions too, and I really ought to do linux versions, and 64-bit linux versions…

There has to be a better way than me spending half a day trying to scrounge up each and every version of Maya. Anybody have any ideas?

Hmm, okay. I guess I will try to compile it on my machine. O_o

Just found a 32-bit machine instead, but still getting the same error.

Could not launch C:\Panda3D-1.5.2\bin\maya2egg85-wrapped.exe

Also have 7.0 on this 32-bit machine, which seems like it wants to work, but fails because the file is from 8.5.

D:\05_06_08>maya2egg7 -a model -o car.egg CAR_v11.mb

Initializing Maya.
***** Error: line 1: Unknown Maya file version: 8.5.
Maya binary file parse error:  : (6) corrupted file structure
***** Error: line 1: Error reading file.
***** Error: line 1:
CAR_v11.mb: (kFailure): Unexpected Internal Failure
:maya:mayaegg(error): Unable to read CAR_v11.mb
Errors in conversion.


Is anyone successfully working with maya2egg85?

I do, have you tried using the mel script?

Yes. I click the export button and it blinks. It doesn’t throw an error, but it doesn’t export the model either.

What is the difference between the “maya2egg85.exe” and the “maya2egg85-wrapped.exe”?

open your script editor before export so you can see the entire error messages, if any.