Cannot load fmod audio library

I’m running Panda3D 1.7.2 on Ubuntu 10.10 32-bit, and trying to enable fmod instead of OpenAL. I’ve updated the /etc/Config.prc file with the following:

audio-library-name p3fmod_audio

But when I start my program I get the following errors:

:audio(error): load_dso( failed, will use NullAudioManager
:audio(error): cannot open shared object file: No such file or directory.

I see the file in /usr/lib/panda3d but cannot find anywhere.

I also tried enabling fmod under Windows running the same version of Panda and had a similar problem:

:audio(error): load_dso( failed, will use NullAudioManager
:audio(error): The specified procedure could not be found

Any ideas?

This is strange. I’m not sure how the Ubuntu installer works, but I’d expect it to include a requirement for fmod to be installed separately, which would provide Still, if for some reason that failed, you should be able to install the fmod package explicitly to get it.

As for the Windows installer, I’m also a little surprised that it didn’t provide the appropriate FMod DLL’s, but maybe that’s not really a good idea anyway since FMod is, after all, a closed-source commercial product. Again, you should be able to get the FMod runtime and install it yourself.


I went and downloaded FMod and ran the makefile but still got the same error.

I then tried the nightly build of Panda from 12/21/2011 but had the same problem.

Do I need to put the FMod library files in a particular directory for Panda to find?