Cannot find libpandaexpress.dll <- Simple solution(s)

When using a different python engine other than my own I ran into an error “Cannot find libpandaexpress.dll”, while I followed the instructions and had a panda.pth file in my python root it did not work (the samples did work).

There are two simple solutions for this bug:

  • Adding “C:\Program Files\Panda3D-1.5.2\bin” to panda.pth as well
  • Adding sys.path.append(“C:\Program Files\Panda3D-1.5.2\bin”) in before it loads the sys.path variable.

A quick google round did not find this yet, so I thought I’d post :slight_smile:

[edit]Cleared up some grammar, added link[\edit]

“When using a different python engine other than my own I ran into an error”
what do you mean by that? Some times panda3d will not work with python it was not compiled with on windows even if its similar version.

I had my own python 2.5 install (installed using python(x,y) ) and preferred not to handle the mess when having several python versions installed.

I followed the instruction found here: and it refused to work properly, giving me the aforementioned error.

I could not find a solution on the forum, but did find other people having issues.

I seem to recall that you’re actually supposed to include more than that in the panda.pth file - including the bin directory, if I’m not much mistaken.

This is, I think, mentioned in the Getting Started Guide thread, but perhaps should be added to the manual as well, if I’m correct.

Yeah, I think it should.

Thanks a lot Itara!

Your tip also fixed the problem for me :slight_smile: