Cannot find any panda3d directorys (MAC)

Seriously everytime I type in /Applications/Panda3D/ in the go to application it works fine yet I type in cd /Applications/Panda3D/ into the terminal and it says “no such file or directory.” I don’t understand whats wrong. I’ve tried it multiple ways. I’ve tried doing ppython but apparently that doesn’t exist either. I’ve reinstalled panda3d multiple times yet I still get nothing. I’m very frustrated with this and would appreciate help. Thank you for reading.

The location is /Developer/Panda3D/ and not /Applications/Panda3D/.

Thank you! It still does not work when I attempt to run asteriods with the ppython line. I navigated to asteroids file and used the command. It gave me this error message:
Traceback (most recent call last):
File “”, line 13, in
import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

Help would be appreciated once again.
EDIT: I also tried this with a textedit file which contained this:

from direct.showbase.ShowBase import ShowBase

class MyApp(ShowBase):

def __init__(self):

app = MyApp()

I’ve added the error to the common diagnostics on this page: … ted_on_OSX

Long story short, you may be running with a different version of Python that Panda was compiled with. Panda3D 1.9.0 for 10.7 is compiled with Apple’s copy of Python 2.7, so you should run python2.7.

Note that in Panda3D 1.9.0, has been renamed to

Thankyou but hoe would I go about making sure Im using the proper version of python, and switching to it?

Specify the full path to the Python executable, like /usr/bin/python2.7, or run “ppython” instead of “python”.

it still seems to not be working. Heres what commands I type in inorder to try and attempt to get asteroids to run

  1. cd /Developer/Examples/Panda3D

  2. ppython
    This gives me “no such file or directory.”
    So I try this instead

  3. ppython which gives me the same message.

So then I tried to run ppython then the “tut-asteroids” or “”
and this happens (here are the steps I took to approach this)

  1. cd /Developer/Examples/Panda3D

  2. ppython

  3. Tut-Asteroiods.pyTraceback
    which gave me:
    (most recent call last):
    File “”, line 1, in
    NameError: name ‘Tut’ is not defined

So I tryed this:
4. which gave me the same message.

I think I might be typing the commands in the wrong order or something. Thank you so much for your patience and help. Please help me with this again.



On the same line. Not on two separate lines. You can use “ls” to find out which files are in the directory, to see what the .py file is called. In Panda3D 1.9.0 and 1.9.1, it is called “”.

Thank you! I finally got it running! Really appreciate your patience with me as well!