Can not compile on Fedora 15 x86_64

I want to compile panda3d sdk on fedora 15 64-bit, but i’v got errors :frowning:
first of all i tried version 1.7.2 and i’v got this error:

In my /usr/include/linux directory there is videodev2.h no videodev.h, so i make link to it and name it videodev.h :wink:
In second round i’v got this error:

What a cruel world!
After reading [url]Panda3d with Ubuntu 11.04], i decide to compile the cvs version.
It starts well and even get to the 47% !!, but then:

I don’t know really what to do to compile and install panda3d to start 3d programming in python. :cry:
Please help me!

It seems not an error on your side: if you check the logs of the last daily build there is the same error, so maybe it is an error that will be fixed soon. You may wait for the fix (or propose a patch) or retrieve a previous version from CVS (one which compiles). If you check the date of the last daily build which has been built, you could retrieve the version of the files corresponding to that day from CVS (I’m not an expert, so take my comments with mistrust :slight_smile: ).

Thanks for reply.
Finally i could compile panda with this command:

./makepanda/ --no-squish --no-opencv --no-artoolkit --no-fmodex --no-egl --no-fcollada --no-ode --no-fftw --no-bullet --no-vrpn --installer

But i’m curious with command above which parts or facilities of panda3d would not work then?
I think egl thing should be important?

Oh, this is my fault, my mistake. I recently added some changes, but since none of my machines have GLES support, I didn’t attempt to build for GLES and didn’t notice the compilation error. I’ve just checked in a fix that I think should solve the problem; I’ll monitor the nightly build to be sure.

It seems like you removed more options from your build then you needed to. --no-egl would have been sufficient to avoid this particular problem, and your Panda build would be perfectly capable without it. egl is primarily useful for mobile devices and other reduced-API platforms; you don’t really need it on a fully capable PC.

On the other hand, all of the other options you removed are fairly exotic things that aren’t likely to be installed on a default Linux system, and aren’t really that needed for a typical Panda build anyway. So your Panda build is still quite capable.