bus error on many tutorial programs gma 950 Mac OS X 10.5.8

Hi people,

I installed Panda3D 1.7.0 on an older Macbook (model 2,1) with Mac OS X 10.5.8, gma 950 graphics chipset, Intel Core 2 Duo CPU and I notice that many demos work and many demos fail with “bus error”.

Asteroids - works
Ball-in-Maze - works
Boxing-Robots - works
Bump-Mapping - works
Carousel - works
Cartoon-Shader (Adv/Sim) - bus error
Chessboard - works
Disco-Lights - works w/o shader, bus error w/ shader
Distortion - bus error
Fireflies - bus error
Fractal-Plants - works
Glow-Filter (adv/bas) - bus error
Infinite-Tunnel - works
Looking-and-Gripping - works
Media-Player - flaky

Media-Player sort of works in the beginning. I can play the video, but I get spam on the console stating, over and over:

[swscaler @ 0x1d5c7000]No accelerated colorspace conversion found.

When I tried to fiddle with the slow motion setting, the program soon crashed with a bus error.

Motion-Trails - works
Music-Box - works
Particles - works
Procedural-Cube - works
Roaming-Ralph - works
Shadows - adv: bus error, bas: scene shows up, then soon bus error, noshader: bus error
Solar-System - works
Teapot-on-TV - bus error
Texture-Swapping - works

I also installed

developer.download.nvidia.com/cg … er2010.dmg

As per instructions.

Does anyone know what’s going on with bus errors? Any help will be much appreciated.

Hey Tealeaf, panda3d community,
I am having the same exact problem. Does anyone have any suggestions. Based on other threads, I am considering downgrading to 1.6. (stable release). I’ll let you know if this works.

One reason why I would like to get 1.7 to work is because the release notes say that it can be used with the webbrowser plugin. I would like to embed my panda3d games into websites. Can the latest 1.6 release be used for web games?



You can have the web plugin installed separately of 1.6.0, and have web plugin applications use 1.7.0. There is no way for web plugin applications to use 1.6.0.

Thanks Rdb, I’ll keep this in mind.

Also want to let others know many of the ‘bus error’ problems went away when I ran 1.6.2 so this may be something to consider.