Bullet not working!

Hi all! Bullet in panda3d not worked! See :

code :

from panda3d.bullet import BulletWorld

but error :

Traceback (most recent call last):
  File "/home/mark/Desktop/StandaloneCoder/Panda/Tanchiki_terrain/main.py", line 1, in <module>
    from panda3d.bullet import BulletWorld
ModuleNotFoundError: No module named 'panda3d.bullet'

What version of Panda are you using, and does your project have a file named “panda3d.py”? For that matter, do other “panda3d” importations work–can you import from “panda3d.core”, for example?

1 Like

Can’t be. It said:
File “/home/mark/Desktop/StandaloneCoder/Panda/Tanchiki_terrain/main.py”, line 1, in

1 Like

@ma3rx, run this code and tell me what you got:

import panda3d

1 Like

I can import panda3d.core . Result you program, @panda3dmastercoder :

1 Like

OK. Did you install panda3d with pip or you did you download the sdk?

With pip install

1 Like

OK. Then uninstall with pip and reinstall with pip. Maybe it will work.
(To uninstall with pip do: pip uninstall panda3d and to reinstall do pip install panda3d)

Thank you, @panda3dmastercoder :slight_smile:

Did it work?


OK. Change this topic to Scripting Issues then make my post the solution.

The fact that there’s one file with another name doesn’t imply that there’s no file with the name in question. :stuck_out_tongue:


Ah, I’m glad to see that panda3dmastercoder’s solution worked! :slight_smile:

I am helping @ma3rx in making the game, and there is no file called panda3d.py

I mean, I believe you–I’m just saying that, based on what I had when I asked, it wasn’t an unreasonable question. It wasn’t impossible based on the one given file-name alone.

And note my “however” above–I recognise that the issue has been solved, and thus that such a file-name was, presumably, not the answer.

OK. The problem as the fact that there was an installation error. So he un and re-installed it.
:slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile:

Indeed! (And I responded to that fact.)

In any case, I’m primarily glad that the solution was found!