Browser plugin nearing completion

The Panda3D browser plugin project is very close to being robust enough to unleash it upon the world.

Before we do, I thought it would be a good idea to unleash it upon the fine folks of the Panda3D community first, so you can get a chance to poke at it and see it work (or not work, as the case may be).

Feel free to check it out at You can share this link with your friends, but do note that this is a pre-release version, for testing purposes only, and anyone who installs this plugin may need to uninstall it later, or at least be prepared to re-install the final version that we eventually release.

Please post here with problem reports.

Known issues so far:

  • An installer is only provided for Windows so far. Other platforms must install by hand. This will be remedied eventually.

  • Airblade isn’t playable on a Mac, because the relative mouse mode it relies on doesn’t work there yet.

  • The Linux release only supports i386 in this version. (Support for ia64, and other CPU’s, is possible, but I only have an i386 Linux box, so that’s what I built.)

  • Some packages are not provided for all platforms in this pre-release version. For instance, wx and sound libraries are not universally available.

  • This has been tested on IE, Firefox, and Safari. Other browsers haven’t been tested, but they might work too. YMMV.


wheee! :smiley: great news! too bad there i s no 64bit linux build. just in case you’r intrested. i think it’s possible to run 64bit VM on 32bit hosts these days.

Ok, i am on Opera and win so will test it for these.

EDIT1: doesnt work with opera 10 out of the box, will look more into it later, downloading Panda3D rev 6 in FF atm.
Which version of Panda is shipped this way? latest dev or release?

EDIT2: here is what happens on Opera, i dled, installed installer (1.6 mb file), tried carousel, didnt work, restart opera, still nothing, go to other tab, go back and area in which demo was supposed to show was overflowed with contents of tab i was last on, like someone pasted image on screen.

Then went to FF, saw black square with pla button, installed panda3d rev 6, and run carousel.
Tried Opera again and it worked.

Confirmed. In Opera, for some reason, it won’t draw the preload splash window, including the icon of the Panda and the big red (or green) play button.

It also won’t launch the authorization dialog required to run an application the first time. This means that you have to approve the application first in Firefox. Once you have done that, you can then run it successfully in Opera.

I’ll investigate these issues more closely.

This is actually the current CVS build, current at least as of the time I packaged the plugin. And it’s not exactly the same build as you’d get if you downloaded it yourself, because my build is different from the usual build. (For instance, it’s running Python 2.4, and other differences.) But remember, this is just a pre-release demo snapshot; the final plugin release will be built with the same version of Panda3D 1.7.0 that you’ll be able to download here.


Also, in Opera, i managed to load Dual window example just once, and FPS in that is terrible with adding just a couple of objects, i dont know is this JS issue or what…

Wow, this is just amazing work.

I am beyond excited. This works great in IE7/Windows 2003, all examples worked as described. (Though when I died in Airblade, I couldn’t figure out how to restart my game. But I suspect that isn’t a problem with the plugin.)

Seriously, if this thing can request/respond over http (via javascript or direct) to a web backend, then absolutely I can’t wait.

OK, it turns out that Opera 10 implements only NPAPI version 1.8. We need NPAPI version 1.9 or better for reliable plugin support. It would be possible to coerce Opera to run most of the time, even on version 1.8, but it would be a little crashy, so I think it would be better to put a check for the NPAPI version at startup and make the plugin refuse to run at all on Opera, or any other legacy-NPAPI browser. (Presumably Opera 11 will update its NPAPI version, right?)

You can do that today in Panda, so, yes, you’ll be able to do that tomorrow too. :slight_smile:


thank you, Panda3d browser plugin is totally awesome =)

I run some demos in google chrome and it worked very well, also, I shared the link with my brazilian comunity.

I can’t wait! =D

great to see this progresssing.

it works fine under snow leopard and firefox, but i dont get a 3d window using safari.

i’m looking forward to get my projects packaged for web-publishing :slight_smile:

Really? Hmm, I might have to find a copy of Snow Leopard and try that out. It certainly works fine with Safari on Leopard.


Do you think there might be a chance that there could be an unofficial build before the final release? So some of us can experiment with it before it comes out? I’m really excited to try this but compiling from CVS scares me to pieces.

@Raz: if you would’ve read the first post carefully you would’ve spotted the downloadlink to the prerelease versions already :wink:

Sorry, I meant to say the entire 1.7 build for Panda, I really want to play with publishing to browser too, hehe. I already downloaded the webplugin and I’m drooling :stuck_out_tongue:

Actually, you can play with packaging your own applications now, especially if you’re on Windows. Download this file: (you might need to right-click the link and select save-to-disk, to avoid trying to run it in the browser).

Then you can use this file, in conjunction with panda3d.exe (which is installed in c:\Program Files\Panda3D), to experiment with packaging your own applications and hosting them on your own web page. I’ve recently added a whole section to the manual that describes how to use packp3d.

Non-windows users can do this too, but you’ll also need to get a copy of the panda3d executable. I’ll have to build one for you, but I can’t do it tonight. :confused:


Ah! Awesome, thanks! :smiley:

Tested windows - works great!
This is looking fantastic.

I set my environment variable, then put the packp3d.p3d file in both the directory I was sitting in, and the c:\program files\panda3d directory.

I got an interesting error after that

C:\Panda3D-1.6.2>panda3d packp3d.p3d -o razTest.p3d -d C:/Panda3D-1.6.2/samples/
:express(warning): error:0D06B078:asn1 encoding routines:ASN1_get_object:header
too long
:express(warning): error:0D09F006:asn1 encoding routines:d2i_X509:bad get asn1 o
bject call
Installing Panda3D
Install complete.
Could not locate Microsoft Visual C++ Compiler! Try running from the Visual Stud
io Command Prompt.


Any ideas?

I’m also getting some errors. I’m not sure if it’s something i’m doing or not, but the panda3D.exe gives me the same error when running any p3d. It’s something about not being able to download the core API.
It also is kind of flaky in firefox, it was working last night but not anymore. Still works in IE though.

Could this be an install issue?

I just accidentally introduced, and then fixed, some bugs in Firefox. Download the plugin again and try it again.

I don’t know what the coreapi problems are. Are they still occurring after you download the latest plugin?

The MS Path is an interesting bug. I know what’s going on–it’s looking for MSVS on your system, in case you want to use it to generate a compiled DLL. I guess it’s probably not installed on your system (and no reason it should be). It shouldn’t really do this until you actually say you want to generate a compiled DLL, so I can fix that–I just never noticed this bug because I have MSVS installed, so I never saw that message. :slight_smile:

BTW, Linux (i386) users can download this program: and Mac users this one: to use in conjunction with the above packp3d.p3d link. Make the programs executable, of course. Note that both of these are temporary programs that should be replaced with the actual panda3d programs when we get the official plugin released.


Actually I have MSVC2005 installed, but I don’t think I have any paths to it yet, so that would make sense.

Downloading the plugin now! (Thanks so much for the quick response ^^)