Blender Model To Egg

I have an animated Blender 2.5 file. I have tried the dae2egg, but without any success.

Could anyone please turn this into an animated egg file, and show me how to do it myself?

Here is the file:


Currently, dae2egg does not support animations, sorry.

I don’t have access to Panda right now, but I do have access to blender so gave it a quick try. For some reason line 6 appears to introduce the tag , using 2.54, as part of the version, without closing it, making the file corrupt. You might want to try manually deleting that and then seeing how much luck you get. I’ll have a look at this unknown thing - that is a definite bug in Blender.

Then why does everyone say to use the Collada format?

Right now there is a transition going on, and the timing of various things has proved rather unfortunate. The decision has been made to convert Panda to use Collada, but that has not in fact been done yet (dae2egg is really a temporary tool - when Panda gets real support it will have to be a rewrite to avoid going via egg, which is to be depreciated.), whilst at the same time Blender 2.5x has appeared. Now, to export for Panda right now requires an egg, but to get eggs out of Blender 2.5x would require completely rewriting Chicken - that is no small task, and nobody really wants to do it knowing that at some point in the (hopefully, though given things going on right now probably not) near future eggs will be depreciated. At the same time the Collada tools are not yet in existence, so realistically whilst some limited support exists for using Blender 2.5x with Panda right now the only real solution is to use 2.49b. Until Panda 2.0 comes out and Blender’s Collada exporter is fully fixed up that isn’t going to change, and I’m afraid that could take some time. People advising to use Collada with Blender 2.5x are saying so because its the only option - its just not realistically a good one.

The problem is my modeller uses Maya. The only way to get Maya models into Blender is using the .dae format. Only Blender 2.5 will import .dae, so the only way I can do anything with his models is use Blender 2.5.

I have been saving these models as .blend from Blender 2.5, then loading them with Blender 2.4.

This has actualy worked quite well. Everything seems to be moving over.

Then he started doing the animations as well, since I don’t have the time. When I save a model with animations as .blend (2.5) then load them with Blender 2.4 the armature gets imported corectly, but the animation does not show.

Is there anyway of gettting the animation out of 2.5 and into 2.4?



Why don’t you just export from Maya directly to .egg?

Because my modeler knows nothing of Panda3d. (And I did not even know there was an exporter… Where can I get it?)

You can find the maya2egg utilities in Panda’s install directory under the bin folder. I think those are what you’re looking for. I’m not someone that uses Maya so I’m not sure if those tools are helpful or not. There may also be mel scripts to perform the egg export directly inside Maya, but I don’t know about that one.

I have also had trouble with Blender 2.5 and dae2egg. I always have to manually edit the dae or egg files that get produced because they’re structured weirdly. Since Panda does not include any sample dae or blend files I can’t tell if it’s just me who is doing things wrong or not. I did not know animation support doesn’t exist yet. That’s disappointing. :frowning: It means everyone pretty much has to go back to Blender 2.49 and earlier if they want to do animation with Blender. I cannot stand the old interface though!

I have tried those tools on a Maya file, and I get weird error messages.

I don’t have a problem using 2.4, but the .dae importer does not work. Does anyone know of a working .dae importer for 2.4?