blender chicken exporter R44 and setTexture issue

just in case I wanna share what I’ve experienced so far - I’ve sent a mail to the dev so now he knows it too and I’ll show you the interesting part:

so I make in blender a simple plane or whatever else uv textured object, static or animated and export it with chicken-R44.
I load and use it in panda and all it’s fine … until I decide to change the texture with the myobjectnode.setTexture method: after that I only get my old texture turned into a big fleck of uniform color. After hitting the head to the wall for long time and then comparing working eggs exported with other exporters I’d found that the r44 use to assign a name to UV in the Vertex section of the egg so I’ve try to stripp it out, such as:


    <Vertex> 3 {
      7.58825731277 -0.0348291546106 -7.48923635483
      <UV> TEXTURENAME { 1.000000 1.000000 }
      <RGBA> { 1.0 1.0 1.0 1.0 }


    <Vertex> 3 {
      7.58825731277 -0.0348291546106 -7.48923635483
      <UV> { 1.000000 1.000000 }
      <RGBA> { 1.0 1.0 1.0 1.0 }

and voila’ setTexture now it works and change correctly my texture.

Hope it helps.

hm… i can only guess the reasons. but that might have been introduced with the support for multiple UV-sets.
R44 is not really recommended to use anyway, even thought its marked as “stable”.
but as long as psiberpunk knows about it things should work out :slight_smile:
thx for sharing your sollution.

Hah! That was probably the problem that I was having not too long ago; in that case I simply dropped the feature for which I wanted it (which wasn’t terribly important, I don’t think) as a result, as I recall, of a looming deadline for the project.

Ah well, it’s good to have the answer - thank you. :slight_smile:

yes Thomas but if you are a blender-guy like me you got no alternatives and I bless the authors to have managed to give us a pretty working exporter! :wink:
but also, today happened something strange:
I tried to replicate the error but this time everything worked out!
I guess yesterday I’ve done something on blender that screwed the script but today I cant’ remember exactly what - anyhow now it works so never mind…till it will come out again! hope to be more sharp to see how to replicate it.

well version 1.0 is out. so r44 is sorta outdated. dunno if this error still exists in 1.0

i thought r44 was newer then 1.0 ?

it is? gosh my brain must have run out of fuel or something >.<
. still as long as the devs know it should be fine.

confirm that r44 is the last one - never mind Thomas, that weird versioning confused me too :wink: