Base screw up? [SOLVED]

Well… This is EXCEEDINGLY baffling… Although it could attribute to my poor understanding of base…

Basically… I just started working with pyPad360, but after I started importing it… base suddenly started screwing up…

One of the main problems that I can mention is how not working anymore.

When I try referencing to it after having pyPad360 imported, it gives the error

AttributeError: ‘module’ object has no attribute ‘cam’

Thats the current main problem…

Another problem is basically me being unable to access base.cTrav from other classes after creating it in the main class, unless I import pyPad360 into that other class as well… (Which in turn causes the problem above…)

Can someone please help me find out how to solve this current main problem, and perhaps explain why base is screwing up?

Hm, maybe it is possible that pyPad360 messes up your builtins ? You should try importing it before DirectStart.

Damn, it doesn’t work… I placed it SMACK at the top, and still the same result…

It sounds like it’s just shadowed ‘base’ with some other definition. Just do “del base” to recover the definition in builtins.


I would worship your feet again if I could, but I cannot because I’m busy with work.


del base after importing all the modules works like a charm.

Thanks drwr! And thanks as well rdb!