Attempted to run a file, and it said it failed to build wheels for wxpython

So, I was attempting to run a file called Run.Cmd, and I ended up getting this error.

I have updated the pip.

If you are using a copy of the python that comes with Panda3D, then you also need to install packages for it individually.

C:\Panda3D-1.10.14-x64\python\python.exe -m pip install wxPython

Hi! Thank you for replying! Tried this method and it resulted in this error…

I think I’ve now realized that you didn’t specify the dependency needed to build the application.

You need to edit the file requirements.txt


I did edit the requirements.txt to include panda3d and wxpython, and it gave the same error! Heres a screenshot that’s past the [end of output] part in case that can help.

Sorry if I’m coming off as annoying!

You should run the wrapper over setuptools - build_apps, not setuptools itself - build. You can take a look at asteroids, for example and read the documentation in more detail.

I suspect that you are actually creating wheels rather than distributing the app. Therefore, my answers above were incorrect, so this does not apply to panda development, the corresponding question should be asked in a more appropriate place.