Assertion failed!

I am hoping someone will be able to assist.
I am having an issue with a game, the developer believes it’s Panda3D related and directed me here.

Here is the error I am receiving:

I have reloaded the game + Patch, latest DirectX and downloaded and installed Panda3D-1.6.2.

Nothing seems to help, I really hope I am able to find some assistance with this error.

Thank you for your time.


Have you downloaded the latest graphics driver from your graphics card manufacturer? This very often resolves problems of this nature.

As to the precise nature, though, it’s difficult to tell much about it without more specific communication directly from the game developer. :frowning: With an error message in a vacuum, we can’t tell much; we’d need to know more about the code that generated the error.


David, Thanks for the quick reply.

I’m sorry I should’ve also included, that I have download the latest graphics driver attempting to correct this issue. But there was no change. :frowning:

I will contact the developer again to see if I can get additional information on this error.

Thanks again for your assistance.

Also, what kind of graphics card do you have; and can you run pview and the demo applications that were installed when you installed Panda?


And (maybe an obvious question) do you also have the latest DirectX 9 runtime installed?

I have an NVIDIA GeForce 8600M GS.
Yes, I am able to run “pview” & I’ve run “Asteroids” without issue.

Yes, I have installed the latest DirectX runtime.

Thanks again to everyone for assisting with this unusual issue.

Well, I guess I can’t help much more, without knowing (a) what version of Panda the game in question is linked with, or (b) precisely what graphics calls the game is making (e.g. is it creating offscreen buffers and how many; what kind of framebuffer is it requesting, and so on).

Although it is arguably a Panda problem, once Panda has been compiled into a standalone game, it becomes the game’s problem. I can’t do much today to make the game run, unless you have the source code of the game available. I might be able to work with the game developers directly to solve problems of this nature in future releases of their game, but I’m not sure how much I can help you, the end user. :frowning:


Hm, I don’t have a copy of Vampyre Story myself, but does it perhaps have an option to switch to the OpenGL renderer rather than DirectX?

If not, is there a libpandagl.dll file in one of the game’s directories? And is there a *.prc file (perhaps gamedir\etc\Config.prc)? If so, you might be able to switch to OpenGL by editing the Config.prc file and replacing “pandadx9” with “pandagl”.

Sorry for the delay in my most recent response.

But since my most recent response I’ve completely reloaded my system, latest & greatest drivers etc…, and attempted to run this game again, still no luck same error.

So I loaded it on another system in the house with an “NVIDIA Quatro FX 3500”, works fine.:imp:

Seems that the problem lies with the “NVIDIA GeForce 8600M GS” video card I have. (Although it’s on the supported list.) :frowning:

Thanks to everyone for there input and assistance.