Animations works in blender and in panda3d doesn't work

i have 2 animations in blender that works fine for the same mesh but when i export it into panda3d i cannot see that animations only one is mouth movement without teeth. but one animation for eyes blinking i animated it with an armature but the mouth was animated by shape keys

and it gives messages like that : :linmath(warning): Tried to invert singular LMatrix4.

You could try Triangulating your meshes first. Might be a good idea to make a backup of your model before you do this.

i tried to Triangulating the meshes but i got the same error. do you meant to apply Triangulating before doing animations or i can do it even after finishing all animations ?

@Thaumaturge do you have an idea about that bro ?

I don’t offhand, I’m afraid, no. (Specifically, I’m not familiar with shape-key animation, and so am not in much of a position to help with things that might involve it, I fear.)

What are you using to get the models out of Blender and into Panda? Have you tried seeing how the model behaves in pview or – if you’re using blend2bam/panda3d-gltf – gltf-viewer?

i used .egg files when i made only one animation with an armature works fine but when i add another action to the same object panda do not make the animation works

My work-around for this is to make a group of separate model files:

  • the primary mesh without animations added
  • a model file for each of the separate character animations

There are probably other ways of doing this, this is just the easiest for me. Naturally, you can apply the separate animations to the same loaded model inside Panda later.

this is what i did with yabee exporter it gives me directly the 3 files the mesh with no animation and the 2 othrs files

As a potential workaround, have you tried implementing your second animation using your armature rather than shape-keying? Perhaps YABEE doesn’t like exporting both, or some such thing.

i exprted them with prebee that exports .eggs as well from blender 2.80: your suggestion is to use either shape keys on both animation or use armatures on both of them ? .egg exporter support armature better than shape keys ?

Ohhh–Do you mean “PRPEE”? If so, then I don’t recommend that: from what I recall, PRPEE is not a fully-featured update of YABEE, and may not work as well as does YABEE. (If I recall correctly, it was adapted as far as suited its creator’s purposes, but beyond that not fully.)

If you’re going to use YABEE, I’d suggest using an older version of Blender and then using YABEE itself.

If you haven’t already done so, I recommend taking a look at this reference thread:

what about yabee, i can use either armatures for all animations or shape keys for all animation not use them both ?

Honestly, I don’t know–I’m not sure that I’ve used shape-key animations with Panda before; I’ve generally used only armature animations. Suggesting that the use of both might have been the problem was only a guess.

Knowing now that you’re using PRPEE, it’s quite possible that the problem lies there, instead.

but when i exported only one animation with and an armature works fine with the prpee exporter but when i add another one with shape keys doesn’t work. do i need to try to use armatyres in both of animations if doesnt work i move to blender 2.79 even if i do not know even to move the cursor in 2.79 lol

You can try implementing both animations via armatures, indeed–see if that works!

Just be aware that with PRPEE some things might work, and some things might not. Baseline YABEE is likely to be more reliable.

i will try it now and see if it works thank you

1 Like