Animations from blender are not visible

Hi I Hope you are having a good day.

I am currently using the Yabee .egg file exporter with blender 2.72.
I made an animation using blender and exported it to panda3d. When I ran the program the program
ran without any errors, except for the fact that the animation is invisible.
The same object is visible when loaded as a model but not when loaded as an Actor.The animation works fine in pview but not in the actual game. I tried searching about the topic, not one of the suggested solutions worked.
I was hoping someone could take a look at my blend file. (405 KB)

Hello! I hope you are having a good day as well. :slight_smile:

Hmm, YABEE gave an error exporting that model unless I disabled “TBS generation”.

After exporting, I created this Python code to load the model and play the animation:

from panda3d.core import *
from direct.showbase.ShowBase import ShowBase
from import Actor

base = ShowBase()

actor = Actor("panda animation.egg", {"walk": "panda animation-walkcycle.egg"})

When I run it, the camera is positioned inside it, but dragging the right mouse button upward zooms the camera out - the model comes into view, and it does appear to, er, “walk” just fine.


how do I disable TBS generation?
May you please post your version of Yabee maybe the is something wrong with mine.
I tried the thing you described with the mouse but the animation is no-were to be seen

I just set “TBS generation” to “No” in the export settings of YABEE. If you got it to export at all, though, that means this is not the problem for you.

Make sure you are selecting all objects when exporting.

You can put this above to put the camera in a position where it is able to see the box:

base.disableMouse(), -20, 0)

Problem solved. Turns out the scale of the actor was to small to see even when zoomed in.
Thanks, I really appreciate the Help.