Animation egg file causing problems with packpanda

hello all
I wanted to use pack panda in order to make it into a self extractable file.
Every time i run pack panda it will give me this error

" :egg(error): Unable to open ./anim.egg
Problem in egg file: .\anim.egg "

This is real as strange i have no problem with that animation in my application.

The error message suggests to me that it can’t find the egg file at all. Maybe there’s a problem with the directory? For instance, maybe the current directory is not what you think it is, so that anim.egg is not in the current directory at the time it tries to run?


Before packing, packpanda will traverse the entire directory, sanity checking all the egg files. I think that’s what it’s doing when he gets this message. Perhaps the egg file can’t be opened for some reason or another — maybe permission bits? Or maybe it really is corrupt?

All my files for the game is in that one folder and i dont understand how the anim file can be corrupt if it works perfectly fine in the actual game

What happens when you type:

egg2bam ./anim.egg -o ./anim.bam

I took out the anim.egg file from the project directory and then it gives me another error saying

" :egg(error): Unable to open ./hand_use.egg

which is the 3d model for my application
pack panda seems to have a problem with my .egg files which work very well within my application

OK. I still need to know what happens when you type:

egg2bam ./anim.egg -o ./anim.bam

I typed this in the command line

egg2bam ./anim.egg -o ./anim.bam

and it will come up with the same error

:egg(error): Unable to open ./anim.egg

I see. Packpanda uses egg2bam, so if egg2bam isn’t working, then packpanda isn’t going to work either. I’ll see if David has any thoughts.

David and I have exchanged messages, and we can’t figure out what’s going on. If you like, you could zip up your project and send it to me ( and I could try to pack it myself.