alt-mouse1 in linux

Hi !
I’ve just changed some of my control camera. I wanted to copy the movement in Maya. That’s mean different movement for each button of the mouse, and with a modifier.

At the end I settled on: alt-mouse1 ( and 2 and 3)
ans control-mouse1 ( and 2 and 3)

No problem on windows.

But on linux, that’s doesn’t work.
I’ve put a other key to do it:

 messenger.accept('x', messenger.send, ['alt_mouse1'])

and here that’s work.

So I’m suppose the modifier are not passed to panda the same way in linux and windows ? ( ALT + mouse 1 move the window in linux…)

My question is : is there a way to bypass that ? in the Os, in the code ?

How do you do it ?

Some Linux window managers eat the alt key, they don’t send any alt-keypresses to the application, so Panda doesn’t get a chance to receive it.

You’ll have to look at reconfiguring your window manager to enable this. Or, you can choose a different key combination, like shift-control-mouse1 or something.


Its true, it happened when I first used blender on linux

If you have Ubuntu 9.04 then you need to go to preferences> windows and under movimentation keys stuff, you set it to use the third option( windows hotkey ), which is a key youre likely to not use.

I’ve tried shift or control or alt to the same thing, but not shift-control,…
Changing the window preference seems easier than changing my key binding. but that doesn’t work !

If I changed this menu preference, then the alt+mouse1 won’t mouse the window any more ( witch is good.) but none of the ctrl + key or alt + key are passed to panda.

So I’ve probably got another thing to changed in the preference,…

The separator is a dash, not an underscore.
And the sequence of multiple modifier keys is always shift-control-alt.

yup! the code here is wrong, but not in my code( it’s working on windows ! ) and I’m not using more than one modifier at a time.

Works fine here.

It seems that with a panda-only application, that’s work.
It seems that GTK work differently on windows and linux and alt-mouse1 ( or shift-mouse1,…) never arrive to the messenger in linux.

I’m going to investigate this issues on gtk forum.