All is white while pview show textures

Hi :wink:

I’m on MacOSX and my friend on Windows7. We were not using relative paths and faced our first compatibility problem there…
That was solved! But the objects still appear white in Panda for him, as the textures are not found!
For me everything is working good, but on that &^#% windows machine: objects are white!

Okay! We then tried it an other way :
Re-assigne paths to to their correct textures on the windows machine.
Export with chicken --> PView shows that objects are well textured but within Panda, objects are still white!

The .egg was removed and re-created by exporting many other times with chicken.
The paths to the .egg are correct as the object appear in Panda but the path to the textures are not as the objects are white!
I can’t see from where the error is coming from!

Any advice ?

[color=orange]Press “L” on keyboard to turn on lighting
I did not read post carefully, sorry.

If your textures aren’t loading, look for an error message in the console about failing to find the textures.



I’m the friend having the problem.

You can see the blender image (top) , the pview image (left) and the panda animation in white (rigth).

I hope someone can help on that.



Yes, it appears your textures aren’t loading when you run it in Python. This usually means a path issue of some kind; the error messages on the console are likely to be informative. What is the console output?


This is what the python console show:

DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)

This is what the blend console show after the export :

Known pipe types:
(all display modules loaded.)
Loading /c/Users/MHM/Documents/Progra/Robot/Robot2.egg
Loading /c/Users/MHM/Documents/Progra/Robot/Robot2-walk.egg

THat’s make me crazy.

I’m asking if windows 7 could cause the loading problem due to some path or things like that ?