actor class kills animated geoms, egg-optchar doesn't care

The actor class is removing a bunch of animated objects from my egg. My actor is made of a bunch of separate objects all attached to one armature. I want to flag each one so it won’t be removed. egg-optchar says the armature joints are all empty, except the first object. When I load the optimized actor in panda3d, only the one body part shows up. Everything looks fine in pview, though. I’ve attached the files if anyone can help!

Possible this is your case: … 9699#79699

Have you tried to use “Merge actor” option on export?

Sorry, I can’t merge the actor because I need to hide and show different parts of the animation in the game. The character will have different animated weapons attached to his arm that need to be made visible/invisible. Is there a way to export as just a single actor, but with multiple geomNodes (parts)?

I am not sure that it is possible, but i’ll try to look deeper.

I got it to work with the old chicken exporter for blender 2.49. The zip includes the original eggs, and the egg-optchar optimized versions that keep all the objects.

My megaman character had all his weapons as different objects, and I just selected the one I wanted enabled with .show() or .hide(). It would be awesome if you could get this to work; I used this feature a lot for mech/robot customization.