A Lander-Style Test of My KeyMapper!

I want to check my KeyMapper module for issues, and I’m hoping that people here will be willing to help in that.

Specifically, what I ask is for people to try out the mini-game attached here, and then mess around with key-mapping. Try both sticks. Try plugging a gamepad in while binding a key. Try silly things. In short, try to break the KeyMapper! I want to know what issues might still be lurking.

(And hopefully people will have fun with the game, too. ^_^)

Game downloads:
Linux 64-bit
Windows 32-bit
Windows 64-bit

(The Windows builds haven’t been tested, but they should work.)

The game that this is attached to is a simple thing: collect ten crystals while not touching the walls. The trick is that the player’s craft controls like a lander: it can be rotated to the left or right, and can apply thrust only in the direction in which it’s pointing. What’s more, gravity is in effect, always pulling the craft downwards. And finally, there’s a catch: collecting crystals involves holding down a button–but the craft’s thrust is disabled while doing so, leaving the player in free-fall!

This is a slightly-modified version of the example-game that I include with KeyMapper on GitHub. Specifically, this version adds:

  • Music (royalty-free)
  • A facility to print the current key-mapping to the console
    • Press “p”
  • Saving- and loading- of profiles via GameSaver
    • If you want to see to location to which it’s writing files, check the console–it should print the relevant directories when run
  • An “instructions” button
  • A “credits” button
  • And a minor change to the specification of the game’s directory

[edit] Now updated with a difficulty slider!

I downloaded the game and started about ten times. I only have the keyboard to play and it is far too difficult for me to survive even 2 seconds once I changed the direction. There is no much chance to test keybindings, if the game kills you within seconds. :smiley: Perhaps add a slider to reduce the gravity so each player can adjust the difficulty. I don’t own a gamepad.

I did wonder whether the game might be a little too hard! Fair enough; I’ll likely upload a new version later today that implements some form of difficulty scaling. Thank you for the feedback!

And done! A new version of the game is available, featuring a difficulty slider. Furthermore, while the original setting is still available, the default setting should be a little easier. :slight_smile:

The links in the first post have been updated, I believe. For the sake of convenience, let me post them here, too:
Linux 64-bit
Windows 32-bit
Windows 64-bit

Sorry to reply that late. I just tested the game and was able to get at least 3 gems. Not my type of game g. But everything worked fine. I pressed all keys and several combinations. No error.

Don’t worry about the delay in reply! And great–I’m glad to read that everything worked! :slight_smile:

Thank you very much for testing–it’s appreciated! :slight_smile: