A Door to the Mists--"Depictions" Demo!

I have a question that I’d like to ask of those who have tried the demo, if I may:

Did you find that you had any trouble climbing while holding a directional key?

I’ve had a report of this, and I’m trying to check on my guess that it’s a keyboard issue, and if so, to determine how problematic it is.

This game looks really competent! And it works good. No freezes or frame drops, very smooth.

Though it crashed after the first combat. Does the game save a log anywhere?

Thank you very much, and I’m really glad that it ran so well for you! :smiley:

Ah, I’m sorry to read of the crash–that’s somewhat surprising!

As to a log, there should indeed be one.

If you’re using Windows, it should be here:

If you’re using Linux, it should be here:

Unfortunately, there is no log file, only savegames and config. I’ll try to get through this scene once again.

OK, now it is here. Looks normal to me:

Known pipe types:
(all display modules loaded.)
:Actor(warning): Cannot control joint head
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body already attached
:bullet(warning): rigid body not attached
:bullet(warning): ghost not attached
:bullet(warning): ghost not attached
:bullet(warning): ghost not attached
:bullet(warning): ghost not attached
:bullet(warning): rigid body not attached
:bullet(warning): rigid body not attached
:bullet(warning): ghost not attached

By the way, it crashes not only after the first combat, but in some random places. E.g. if I stnd under the rope, facing away from it, and make a step back, it will 100% crash.

I’ve uploaded a save game of the case. Load it, make a step back, and it should crash.

Saves.zip (633.7 KB)

Cannot complete the tutorial combat yet… It is super irritating. Found another bug, after 3 consequitive savegame loads the frame rate drops to 20. Maybe you have a memory leak somewhere.

OK, I’ve completed the tutorial. The combat was really annoying, because the tutorial windows kept popping up and distracting from the fight. It took about 20 attempts to win.

Also, using the rope is somewhat counter-intuitive. I spent some time guessing how to use it, and then it took around 20 attempts (again) to get from the lower rope to the upper one without falling in the shaft

When I got to the top, I realized that I’ve forgot the wrapped thing below. And this time it was totally impossible to get down without falling, so I had to redo the combat.

Sorry if the critic sounds harsh. I didn’t mean to, I just want it to be useful!

I think that in situations like rope-climbing the game developer should lead the player by hand. E.g. stick to the rope once you clicked it, and automatically slide up/down.

Not at all! I’m grateful for such honest feedback, so thank you for it! :slight_smile:

That’s really weird–this is the first report that I’ve had of such a thing!

Thank you for the save–I intend to try loading it and seeing whether I encounter the same crash on my system!

That log file that you posted above–does that come from directly after one of the crashes? (That is, without running the game again between the crash and reading the log-file.)

I do indeed see no error output in the log-file–but then I have had some trouble with errors not being logged. :/

Oof, that’s troubling to read! Thank you for reporting it–it’s entirely possible that I’m not cleaning something up entirely! I intend to look into this.

Ah, I’m sorry to read that it was so negative an experience! :/

But indeed, I have had other negative feedback on the combat mechanic–and thus I’ve reworked it significantly in response to that feedback. I’m hoping to include the revised mechanic in a new version of the demo (which I intend will also include a number of other tweaks, changes, and bug-fixes).

However, in the meanwhile I have a prototype of the reworked combat mechanic, if you’re interested in trying it out:

I’m not quite sure of what to do about the tutorial–it’s somewhat important that it be there to instruct the player, and also that it pause the combat in order to give the player time to read it. This calls for some thought, I feel.

Interesting! Again, I’m sorry to read that your experience was so negative! :/

If I may ask, what did you find unintuitive, and how were you attempting to use it?

For the sake of clarity, it should be entirely possible to get down the rope without falling: just drop in and press the “jump” key to catch onto the rope. (Once you’ve cleared the ledge.)

You should be sticking to the rope once you’ve grabbed onto it–were you not? If you were finding that you were dropping off, then that may indicate a bug.

As to automatically climbing up and down–if I’m reading you correctly–that’s something that I’m rather strongly against, myself. It’s something that I’m inclined to dislike in games, I think. I think that I’d rather have–and thus rather my players have–control over when and whether they jump off of ladders and ropes.

All that said, due to other issues with the ropes in that level, I’ve actually removed them. In the intended-to-be-upcoming version of the demo, the platform-lift should instead return the player to the top (and back down, if they want to re-enter).

That said, while I may disagree on one point above, I do very much appreciate all of your feedback! Thank you very much again. :smiley:

No, it seems not. Just a regular exit. The game doesn’t create a log after a crash.

Battle mechanics are OK, but the golem attacks right after I close the hint window, so I have no time moving cursor to parry… Maybe you should make him slower?

I think the rope climbing mechanics is right, but it needs tweaking. E.g.

  1. Activate the climbing state with a click, if you are at the low point, or with walking over the hook if you are at a higher point
  2. Increase the radius of the click
  3. Lock player from falling when on the rope etc

But that’s me, maybe you like to give the player a challenge figuring it out?

I’ll try it out, thanks.

Ah, that’s frustrating! I have indeed been having trouble with things like that happening, but haven’t found a way to making logging more reliable. Sorry about that! :/

Aah, I see–fair enough!

And indeed, I actually have a new tutorial window for the “special attack” phase of the tutorial, that actually requires the player to press a “dodge” button before it disappears–thus the player should dodge immediately on the window closing.

But yeah, it’s not a bad idea to introduce a bit more of a delay between the tutorial window closing and the enemy reacting, I think–thank you for the suggestion. :slight_smile:

Hmm… Clicking might be done–it’s something that I’ve considered in the past, and I can give it more thought.

(There is one concern: that players might not learn at all that ladders and the like can be caught in the same manner as ledges. This might cause some traversal challenges to become more difficult, as clicking in mid-jump might be tricky…)

Having the player automatically climb just by walking over a rope or ladder is something that I don’t want to do: I want that sort of thing to happen by the player’s choice.

That can be done, I think. (If I have more ropes in later levels–while there are ladders (which I think are likely wide enough already), I haven’t settled yet on whether there will be other ropes.)

That… should already be the case? Right now the player shouldn’t be falling off unless they jump off. (And I do want players to be able to exit ropes and ladders at whatever point they want.)

Are you finding that you’re not staying attached to the rope?

Heh, it’s not supposed to be as much as a challenge as you’ve found it to be, I fear! ^^;;

Thank you! I appreciate it. :slight_smile:

Well, I meant a more “safe” way, e.g. go in and out the climbing state ONLY with a click or a specific button, but you are already said that it doesn’t fit your game, so I am OK with this.

Or maybe you should include the rope climbing part in the tutorial as well?

P.S. Can you give me a hint how to get inside the tomb? I found 2 symbol pieces, but I can’t find more.

Ahh, I see–thank you for the clarification. Fair enough, then! :slight_smile:

The third piece is inside one of the tombs–you’re going to want a way to get past one of those doors.

As for a more immediately-useful hint: Have you done any climbing yet in this level? If not, perhaps look for things to climb… :wink:

Thanks. By the way, this thing didn’t look climbable at all… Maybe you should add a hint?
Again, I am stuck. This time - in the second tomb, I can’t seem to solve the journal word puzzle. Could it be that I don’t have enough words in the lexicon?

Well, based on feedback I have already removed the leaves on the tree, so the climbable branches should be more visible now. I might give some consideration to adding some other indicator, however!

(I do have it in mind to add such an indicator to another climb later in the level, at least.)

If you can open the puzzle, then you should have enough word-roots in your lexicon–the game should refuse to open it and inform you of the lack if you don’t.

I take it that you’re in the long room with two sarcophagi, two doors, and a hole in the wall by which you entered?

One hint that I’ll give is that some word-elements are grammatical in nature, and don’t need to be matched. For example, “OL” at the end of a word indicates a plural, and “SEK” at the start of a word indicates the possessive.

Hi @Thaumaturge, thanks for your tips. I’ve solved the word puzzle in the long room, but can’t figure out what to do next. Can you give more hints, please?

Sure! (And well done on solving the puzzle!) :slight_smile:

Hint 1: Have you tried picking up one of the chests scattered about the long room?

Hint 2: In the room just before that–the one with the open sarcophagus–have you noticed any rubble lying around?

  1. Yes, this have annoyed one of the mummies, which I killed. This didn’t changed anything, at least I didn’t notice.
  2. If you mean borken bricks and blocks then yes, they are here. Still, I don’t get what they should mean. Neither I found anything that is usable near them.

Found another bug. Sometimes the battle never begins. The battle scene loads, but the characters stand still, with idle animation playing.

P.S. Happy to playtest your game further.

Fair enough–I wasn’t sure that you had gotten that far. The battle doesn’t change anything, as such–rather, that mummy blocks access back into that smaller room.

Well, where did they come from? Some clearly came from the hole in the wall, but there should be a pile near a corner that’s not composed of wall-blocks.

That’s a new one! I don’t think that I’ve ever seen that happen! Can you attack when this happens? If so, it may be an AI bug.

(It’s hard to say offhand whether it might happen under the revised combat mechanic, so much having been changed.)

Thank you! It’s appreciated! :smiley:

And I hope that you’re having fun doing so. :slight_smile:

Yeah, I’ve already found it. Some games use light sources to guide the player around the level. Maybe you should put a light source in a room above? Just an option.

I can’t do anything, only Alt+F4 out of the game. Also, I think the frame rate should be low for this to happen. I think a good way to reproduce it, you need to load a game couple of times to get around 10 FPS, and then start a battle.

The worst bug so far is frame drop after I load a savegame.

Ah, I’m glad that you have. :slight_smile:

I mentioned before (if I recall correctly) that I had in mind another place in which I intended to add further traversal-guidance for the player–this is it.

That said, I currently intend to do so via some marks on the wall, rather than light–I don’t want to have too much artificial addition of lighting in this game.

(Not that I intend to have none–I just want to be rather sparing with it.)

(And I do appreciate the suggestion! ^_^)

Weird. o_0

Okay–that gives me an avenue for investigation. Thank you for that!

Yup, that is a nasty one–it’s high amongst my bug-fixing priorities! :/

I continue to playtest the game. The second level is great. I had so much fun exploring the brass city.

Bugs: I haven’t encountered any new ones, good job with this level! But I have some questions/notes about the level design.

  1. Once I entered the undeground city and walked right, I jumped and fell between two walls in a very narrow alley, from where there were no exit.

  2. In the beginning of the city, in the house with a trapdoor leading down and without a ladder, there’s a room with a broken chair. I think you are supposed to use this chair to get out, but this was impossible for me.

  3. You can take the portable ladder with you through other ladders, sticking it to the same wall. This way you can skip some puzzles.

  4. What’s the point of the house with the grappling hook near it? I got there using a broken chair, but there were nothing inside except for two more broken chairs.

  5. Every alley in the city looks exactly the same. Maybe you can add some more landmarks / color coding to tell them apart? Or add the text on the sing posts. Or different background noises / music. Or vary materials a bit in every isolated parts of the city. Etc.

Overall, my experience is positive. This is a very atmospheric level.

But I am stuck after finding the adventurer and getting out of the barred window. Where is Elsa’s house? Is it the house with a jammed door and a book that is visible through the window? I have no idea how to get there.

Ah, that’s great to read! I’m very happy that you’re so enjoying this part, and of the lack of bugs! :smiley:

Oh dear! I thought that I’d gotten rid of all such locations, but it seems that I missed one. I’ve made a note of it, and intend to try to find and rectify it. (I intend to do some work on that level at some stage anyway.)

Is that the house accessed after the rubble-slope? If so, it should be possible to get out if you put the broken chair on the

Yup, this is somewhat intentional. (There’s even a secret to be found this way.)

I do want to be sparing with such ladders because of this trait of theirs, of course. But conversely, a big part of the traversal in this game is finding your own way through the level. If you prefer to lug the ladder around, then I see nothing wrong with that!

That’s the building that you first enter on top of, right? The one with a partially-missing floor inside the upper storey? If so, then those two chairs form part of the means of getting back up to the entrance/exit of the level.

Believe me, I really, really want to–but I’m just one person working on this thing, and I don’t want the project to stretch on for far too long. :/

Still, I’ve been giving thought to it, and I do want to try to include some variety in city-scenes like this…

Ah–perhaps I should make that goal-text clearer, then. Elisal’s claim is a separate part of the city from this adventurer’s. Thus the goal immediately after talking with the adventurer is to exit the level by the same way that you entered.

On another note, I’ve begun looking into some of those bugs that you reported.

To start with, the crash: I believe that I see what happened there, more or less at least. It seems that the game ended up under the impression that you were climbing–but without a record of what ladder/rope you were climbing, which was a problem. The game, seeing that you are climbing, tries to access the ladder/rope, and crashes when it finds none. :/

Since it looks like there’s an oversight in the code that saves the reference to the player’s current ladder/rope, I’m guessing that you saved while climbing, and that the oversight resulted in this invalid state.

So, I intend to fix the oversight in saving and loading, which should hopefully prevent the same thing happening in the future!

As to the slowdown on restoring a save… I’m not seeing that happen on my end. I did uncover a few things that weren’t being properly cleaned up, but nothing that seems likely to cause any slowdown…

Still, I can try testing under Windows to see whether the problem is specific to a given platform… (I develop under Linux.)

Also, just to make sure that I’m testing correctly, what I’ve been doing is saving (e.g. via a quicksave), then immediately loading the save, then loading it again, and again, each new load being done pretty much as soon as the game has finished with the previous load. Is that the correct procedure?