A Door to the Mists--"Depictions" Demo!

[Minor update: 20 October, 2020]

[Major update: 6 October, 2020]

"Adventure is My Path"

Traversal, Puzzles, and Combat in a Heroic-Fantasy Setting

The “Depictions” Demo is now available!

You should find it here:



This version, version 0.9.0, includes a variety of changes:

  • Reworked aesthetics
    • The in-game look has been changed, made more clearly stylised–and improved, I hope!
  • Additional content
    • Two new (small) locations
    • New puzzles in one of those locations
    • One new enemy
    • One collectible and new lore-entries–but showing those would be spoiling things. ;)
  • Plus a variety of tweaks, fixes, and changes!|

About the game:

An adventurer with a yearning to explore the inaccessible, misty world of magic hears a tale of a door that opens onto that world, located in a lost city. She embarks on a journey through desolate and dangerous places to discover this city and its door, and enter the mist-world.


  • Traversal and exploration, with universal mantling
  • Puzzle-solving, both in-level and via minigame puzzles
  • Combat, sparse and one-on-one


Congratulations on the demo release :slight_smile: !

Sadly, I have the problem of the demo not running after closing the “A Quick Note” window by either clicking a mouse button or hitting a key on the keyboard.

The log file that is generated is of the form log.<date-and-time> and is completely empty, so it probably does not provide much help as to what is going wrong, except perhaps for its very existence, as you have already reported the creation of such files to be unintended, I believe.

Here are the specs of the two different machines on which I tried to run the demo:

  • Laptop:

    • OS: Windows 10 Home 64-bit
    • CPU: Intel Core i5 7200U @ 2.50GHz
    • RAM: 8GB
    • Graphics: Intel HD Graphics 620 + 2047MB NVIDIA GeForce 940MX
  • Desktop:

    • OS: Windows 10 Home 64-bit
    • CPU: Intel Core i5 6400 @ 2.70GHz
    • RAM: 8GB DDR3
    • Graphics: 2047MB NVIDIA GeForce GTX 750 Ti

Note that on the laptop, I tried running with the Intel as well as with the NVIDIA card, but the issue occurred with both.

Thank you very much! I really appreciate that! :smiley:

Argh, that’s a pity! That issue really is proving more prevalent than I’d hoped. >_<;

Actually, I’m somewhat mystified at the existence of those log files–they’re not what I’m generating. My log file should be in your app-data directory, in a folder named “ADoorToTheMists”.

(Under Linux, that’s “/.local/share/”; under Windows, I think that it’s in “Users//AppData/”, or something similar.)

However–and related to my logging thread–my log-file isn’t proving helpful either, as the actual stack trace seems to be part of what isn’t being written to them for some reason. >_<

I’d love to know what’s causing those “log.” files to appear. :/

Thank you very much for the report! It’s appreciated! :slight_smile:


It turns out that the current build has a serious issue, in which on some machines the game crashes when trying to show the main menu.

I think that I have an idea as to what the problem might be–the use of non-power-of-two textures–and intend to start investigating on Monday. If all goes well, I hope to upload a bug-fix version sometime around Tuesday.

(I intend to post, here and elsewhere, once I’ve done so.)

My apologies for this! :/

I also have a crash after the screen with a suggestion to press any button. Windows x64

Fair enough, and thank you for the report! Hopefully the next version will fix this issue. >_<

Ah, what a tease. After getting quite intrigued for the game by a series of intros, I am met only with a loading screen that appears to do nothing but warm up my laptop. I’m using the Linux build, by the way.

Is there any way I can find out what it’s stuck on? The log file doesn’t seem to have anything of interest. Breaking into it with a C++ debugger suggests it’s just rendering things and isn’t stuck on any call in particular.

When I noticed the “Lore” button, I figured I’d console myself by diving into the game’s undoubtedly rich lore, but alas, imagine my consternation upon finding naught but an empty DirectScrolledFrame. :frowning: Something to look forward to in the real version, I suppose!

EDIT: Oh, actually, never mind that; I started it again, and skipped the intros this time, and it loaded into the tutorial this time.

Wow, I’m really impressed with what I’m seeing so far.

I feel really dumb to ask this, but any hints for the tutorial level? I’m just not managing to scale the black pyramid. I tried all four sides but I’m just not managing to climb above the level that the stacked stones will get me.

Furthermore, it’s a little awkward that the key controls default to WASD, rather than reading out what keys WASD correspond to on the current keyboard layout (as determined by base.win.getKeyboardMap()); it means I had to switch my keyboard layout to QWERTY before playing it.

Oh, and at certain window resolutions, some of the text in the beginning of the first intro (in this screen) gets cut off at the sides.

Excellent work, though! I’m looking forward to playing the rest.

Hah, yeah, the first load or a given level can take a while, I fear! (Although I’m surprised that it’s happening with the tutorial level–that one’s rather small… o_0)

I’m tempted once again to look into threaded model-loading, which would allow me to at least put up an animation to show that the game hasn’t frozen…

But if it’s actually leaving the black overlay on-screen after the level has finished loading, then I’m surprised–I don’t think that I’ve seen that happen… o_0

Alas, I’ve been having trouble with logging, as described here. However, it looks like the fixes should be fairly simple, based on feedback in that thread, so hopefully that will be improved in the bug-fix version that I hope to post soon! (Perhaps sometime around Tuesday.)

(And note that the “log.<date-and-time>” files are not in fact the ones that I’m logging to–those were being generated unintentionally. The actual log file should be in your “app-data” directory–under Ubuntu, that should be “/.local/share/ADoorToTheMists/”, if I’m not much mistaken.

However, due to the above-mentioned logging troubles, this still likely won’t have a stack-trace in the version of the demo that you currently have.)

Hahah, I think that I’m going to add a title to that page: it doesn’t hold lore available from the start, but all lore collected during play, regardless of reloaded saves.

To explain: As you find lore in the game, it becomes available from an in-game screen (alongside the inventory). But this is tied to your current progress: reloading an old save results in the loss of any lore-entries that were found after that save. However, not so with this main-menu lore-collection: if you found it at all, it should be there.

(I may add said title in the bug-fix release; it should be simple enough, I daresay.

Thank you very much! I really appreciate that! :smiley:

Hah, I worried a bit about that! The main trick here is to know that, while you can’t walk up steep slopes, you can pretty much walk along them. So if you look at the blocks facing the entrance-gate, you should see a spot where climbing up will gain you enough height to scramble along a slope to reach another block…

(I think that I’ll consider changing that aspect of the tutorial-traversal…)

Ah, I’m sorry to read of this trouble. :/

I wasn’t aware of “getKeyboardMap”–I should look into that at some stage, indeed! Thank you for mentioning it!

(That will likely be in a later version, however, and not in this demo, I’m afraid. ^^; )

Oof, that’s a pity! Could you give me a resolution in which that happens, please? That way I can load the cutscene editor in that resolution and perhaps move things around a bit.

Thank you again–that’s really heartening to read! I hope that you have fun with it! :smiley:

This looks very well made, congratulations, and best of luck with the bug fixes!

Thank you very much, on all counts! I appreciate it! :slight_smile:

Dear developer, the deadline has already arrived, but there is still no game. How much can you delay with the release? Maybe it was worth releasing as is customary in the gaming industry, first a 10GB patch, and then a game? :slight_smile:

I did say “perhaps sometime around Tuesday”–I see no hard deadline there. :stuck_out_tongue:

And anyway, I’m with Douglas Adams, who said something to the effect of: “I love deadlines. I like the whooshing sound they make as they fly past.” :stuck_out_tongue:

More seriously, however, I’m currently building a new version. But it does take a while, and I still want to run at least a quick test before uploading it.

That said, if all goes well, it may perhaps be ready in a few hours time! (I will likely announce here (and elsewhere) when I do upload it!) :slight_smile:

[edit] I could have posted a build earlier, I think–iiiiif I didn’t mind leaving in the ability to skip to any level at the press of a number-key (and likely a crash if the player pressed too high a number). ^^;

A new build of the demo has been uploaded!

This build fixes a major issue in which the game would crash after the first screen when running under Windows, as well as addressing a few other matters.

Get it from the same link as given before. That should be found above–but for the sake of convenience, let me link it here, too:

Windows 64-bit Build | Linux 64-bit Build

Updates in this build:

  • The crash observed when leaving the first screen under Windows should now be fixed!
  • Made the tutorial-traversal a little clearer and simpler. (Hopefully!)
  • Added an indicative title to the lore-screen that’s accessed from the main menu.
  • Logging should now work properly.
    • The log-file should be found in the game’s “app-data” directory:
      • Under Windows, this should be “Users//AppData/Local/ADoorToTheMists/”
      • Under Linux, this should be “/.local/share/ADoorToTheMists”
  • Fixed a bug that could result in a crash if the player entered combat while a conversation was ongoing.

I definitely love exploratory games. However, the combat system is not good, I can’t even damage the guard. There is also an error with the quick save button, if you press during the battle, the game crashes.

Known pipe types:
(all display modules loaded.)
:Actor(warning): Cannot control joint head
:bullet(warning): rigid body not attached
:bullet(warning): ghost not attached
:bullet(warning): ghost not attached
:bullet(warning): ghost not attached
:bullet(warning): ghost not attached
:Actor(warning): Cannot control joint head
:task(error): Exception occurred in PythonTask eventManager
:GameMessages(warning): Traceback (most recent call last):
  File "GameCore.py", line 1262, in <module>
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 3124, in run
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 531, in run
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 485, in step
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 49, in eventLoopTask
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 43, in doEvents
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 99, in processEvent
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 333, in send
  File "/home/thaumaturge/Documents/My Game Projects/DoorToTheMists_DEMO/build/__whl_cache__/panda3d-", line 418, in __dispatch
  File "GameCore.py", line 949, in quickSave
  File "GameCore.py", line 1007, in save
AttributeError: 'CombatArcadeWorld' object has no attribute 'levelName'

I’m glad to read that! :slight_smile:

Hmm… I’m sorry to read that you’re having trouble with it. Perhaps I should have included a more-detailed tutorial, or reduced the capabilities of that guardian… :/

Could you elaborate a little on how the fight goes, please? And are you finding that the guardian blocks too easily, or something else?

Oh dear! I’m sorry about that! :/

Thank you very much for the error report–it’s helpful, I do believe!

I think that I see what happened: it’s not intended that the player be able to save during combat–and so I perhaps haven’t tested what happens if the player presses the “quicksave” button at that time. That’s something to be fixed, I daresay! :/

(And thinking about it, it might be wise for me to have some indicator appear when the player tries to save during combat, to show that saving is disabled.)

Firstly, the forced transition to the fighting stance is annoying. I remember that such a system was in Mafia 2, but I like it in GTA, the combat stance is only when you click on this button.

Secondly, it is not possible to clearly define the time frame when damage can be caused. There is also no sound of damage or impact on the enemy. The beat is too slow.

Thirdly, yes, it blocks too often. This imposes problems against

Oh yes, I defeated him.

Just why is he in the air?

I seem to have found a way to get stuck on the second level.

Really? That’s interesting. Would you walk me step-by-step through the process that you’d prefer, please? (I haven’t played either Mafia or GTA, I’m afraid.) The player enters combat range with the enemy–and then what happens next?

Hmm… I might have to think about that. I don’t want the experience to become too arcade-y.

The basic idea is (or is intended to be–it’s possible that detection isn’t perfect) that damage can be taken when an attack is being made by one or the other combatant, and their opponent meets their weapon. So, if you step into an attack, it will land earlier than if you’d just stayed still.

Hmm… There should be. Perhaps I’ve left the volumes of the sound-clips too low?

I take it that you mean the pace of the fight? Fair enough–in this, at least, it might be a clash of tastes in combat-mechanics.

It’s largely inspired by the combat found in the Quest for Glory series of games (well, the first three, at least).

This, I think, may be a failing of my tutorialisation: the expectation is for the player to look for openings: side-step, counter-attack, etc.

Oops! I’ve seen that before, but only after reloading a save, as far as I recall. I’m afraid that it’s a bug that’s rather low on my list of priorities, at the moment. ^^;

(A place to see it very clearly is in the next level: after fighting that enemy and winning, save and reload. It should be floating just above the surface below. ^^; )

(I think that it’s caused by the logic that I use to place such objects, and the way that I handle posing them after defeat in combat.)

Oh dear! I’ll look into that, I intend–thank you for reporting it!

Just when you press a button, this is usually TAB, focuses on the enemy, when released, you can move freely.

There is sound during the strike, but it is not clear whether there was damage. Of course, there is HP to watch, but in the dynamics there is no time to look at the interface.

I mean the speed of the blow, or rather the animation. She looks inhibited.

As for getting stuck, this does not always happen.