3DS Max 2008

The name of the collision object in Panda comes from the name of the in the egg file, which in turn usually comes from the name of the mesh in the modeling package that created it.


That panel is used to be on the right side, on where you can input the name, typed-in transforms, etc.

Ok, where can I find the mesh name. I’m also new to modeling and so I have no clue where I can find this. I’m using Maya 2008.

I have tried using the mesh name of the objects as well as several other names that could possible be related to my object to no avail. Is there anyway in Panda3D to check if an egg file has a collision mesh attached to it?

Easiest way is:


and look for a node of type “CollisionNode”.


So if I had a model named Person, I coudl do:
print person.ls() ?
Also, is there an egg2maya program?

Just person.ls(). No need to print. And yes, there is an egg2maya. Note that maya2egg followed by egg2maya is not a lossless transition.


Using the .ls() method, it’s been determind that my model does not have a collision mesh. I have followed the instructions in the manual on how to export from maya, and I guess it’s just not working. The script imports properly and executes without error. And I can assign type of collision mesh. I guess it’s just not exporting properly. Is blender easier to export with. What we’re working on is a school project, and it’s due after next week. We just need basic models and so I’m looking for the simplest way to do this.

You’re going to need to figure out where it went wrong in the conversion process, in order to figure out how to fix it. For instance, wouldn’t you feel silly if you switched to Blender, re-did your model in Blender, then converted it from Blender, only to find out that you have the same problem in the Blender model because the real problem was that you tagged the wrong node with the “collision” flag?

I’m not saying that’s the problem. I don’t know what the problem is. But I can assure you that collision models normally have no difficulty converting from Maya, so whatever the problem is, simply switching from Maya may not be enough to solve it.

Examine the egg file that you converted out of Maya. Does it have { barrier } or whatever tag you applied? This is how Panda represents a collision mesh. When you load the egg file, are there any error messages?


I don’t believe I’m doing anything wrong. I’ll post exactly what I do here so that if there are any errors maybe someone could point them out. I create a simple polygon sphere. Give it a phong material attribute which is a png (the texturing works fine). I then, follow the proper steps in the manual of importing the MEL script and setting it on my shelf. I then select my sphere and click the button to assign the collision attributes. I then go to the sphere objects attributes, and set the EggTypeObjects1 to barrier (the equivalent of polyset keep descend or whatever). I save the file, and exit. I open the command prompt (and switch to the proper directory) and enter in the command, making sure to use maya2egg2008. I do get a list or errors, but the file is written anyway. The errors are unable to find maya’s python environment. There are no errors though when Panda3d runs.

Yep, sounds like you’re doing everything right. You need to examine the egg file. Does the egg file have the { barrier } field within it?


Nope. Can I just add that in to make it work?

Oh, it’s the Dart tag. I remember that was the 1st reason why I altered mayapandatool. Use mine :

If you’re using the command line maya2egg2008 program, and not the plugin that ynjh_jo is referring to, then the dart tag is being introduced because you’re providing the incorrect command-line option “-a model”, which is only appropriate for animated models. In order to convert models that include collision geometry, you should not use this option.

I’m not sure if the dart tag would suppress the , though. There might also be some other, unrelated problem.


ynjh_jo, your exporter link is broken. The file isn’t there.

When exporting with just “maya2egg2008 -o [blahblahblah]”, the Dart tag is gone, but still no collision.

So, for some reason, maya2egg doesn’t appear to be seeing the ObjectType flag you set. By what means are you setting it?


Here is a screen shot of how I assign it. That attribute appears after using the mel script to give it the attribute.