1000 Ralphs marching

I’m using a few day old Windows build (Panda3D-2010.11.18-35.exe) on Windows 7 and getting the following warnings and error when trying to get the PandaSE, http://www.etc.cmu.edu/projects/pandase/downloads.html, instancing example to work:

I’ve just updated my graphics card drivers and it made no difference. Any ideas?

Have you tried setting the “basic-shaders-only #f” in the configuration?

Yip, no change. This same thing worked for me with build Panda3D-2010.10.27-5. I’m going to install it again and see if it still works.

I’ve just uninstalled and reinstalled the older version, which did not work. Then uninstalled and reinstalled the newer version, still didn’t work. Then I uninstalled the ATI drivers and installed the latest drivers, and I still get the same error.

Can someone please confirm that this instancing example does work with the latest Windows build, and on what system?

I’ve even tested on 2 other pcs, one has a Geforce and the other also an ATI, both Windows 7 64bit, neither worked.

EDIT | Sorry Geforce one works. Why would ATI not work? My work pc has an ATI, I really need to find out why…

Try selecting a profile in the shader that supports instancing, and making sure your GPU supports that profile.