100% cpu one of cores, this is normal behavior?

I try launch documentation sample and one of my cpu cores working on 100%

This is likely normal behavior if you have vsync enabled. Some drivers will do a busy wait or spinlock to wait for a vblank event. This means that your CPU will waste time doing nothing, which will show up in task managers like this. However, this also means that there is more room to do real work prior to waiting for the vblank that you can utilize before taking a framerate hit.

If you don’t have vsync enabled, then Panda will be trying to render frames as fast as possible, which is likely to consume the full CPU core if the GPU doesn’t have much work to do.

Yes, by default, Panda will run as fast as it can, using up all your CPU. This is a feature, because when you’re running a game, you want it to run as fast as the computer allows, because you’re not doing anything else at the moment.

Just adding a time.sleep(0.001) in a task (or putting client-sleep 0.001 in your Config.prc) will yield time to other applications.