1.9.2 requirements


Sorry to be a pain but I have a couple of questions about the new SDK. I have been using 1.9.0 but I have a compilation issue with the a newly installed version of the sdk 1.9.0 that I don’t have with my originally installed 1.9.0 SDK due to changes in nodepath. (I can’t assign a PlaneNode pointer to a Nodepath any more), so I decided I’ll just install 1.9.2 (which presumably will give me the same problem). But are there pre-built third party libs for 1.9.2 as there was with 1.9.0 and what version of Bullet is recommended these days?


I’ve got the new SDK working ok, it seems the pre-built libs are included now in the third party tools. However I have a problem which I don’t have in the old version. One is how do I assign a PlaneNode to a Nodepath, I was previously doing

Nodepath np = new PlaneNode("name"); 

Now this doesn’t work. I tried to use

np.attach_new_node(new PlaneNode("name"));

instead but now I get an assertion failure in NodePath presumably because np isn’t initialised. I’m probably missing something obvious.


This is the correct way to initialise a NodePath with a node:

NodePath np(new PlaneNode("name"));

This is because the relevant constructor is now marked “explicit” so you can no longer implicitly cast a PandaNode pointer to a NodePath.

Thanks, although one one of my machines I’m getting the attached error. A bit odd since on my other machine it works fine. I guess I’ll need to work out what’s different, just wondered if anyone had seen that before?

I solved the above error by uninstalling the 1.9.0 version of the Panda SDK I had installed. I do have that version on my other machine which wasn’t affected but it’s a later revision so they’re not exactly the same, or there could be something else going on. Anyway, I doubt running two SDK’s together is a good idea.