Yet Another Blender Egg Exporter (YABEE)

yabee
blender

#421

I think I know a way that will satisfy everyone.
I will make an UI panel that will gather and call settings relating to the YABEE, but indeed it just will be linked to the relevant native Blender parameters. May be it’s really will be optional “yet another interface” :slight_smile:


#422

Hey I tried installing Yabee, I put io_scene_egg in the addons folder but nothing showed up in the export gui? Any help? Sorry If I don’t have enough information, just ask what I need to post, thanks!

Edit: I’m using Blender 2.66 and Yabee is giving me this error : Fake moudle: addon missing ‘bl_info’ gives bad performance!


#423

Try to remove io_scene_egg, then install by another way: Run Blender, then press Ctrl+Alt+U -> select “Addons” -> press “Install from File” -> select the downloaded *.zip file with YABEE -> “Install from File”. After installation you can find “Import-Export: Panda3d EGG format” in “Addons”. You must check the box to use it.


#424

Thanks ninth! :smiley:


#425

+1
Man, you’re great :slight_smile:


#426

I found out that Yabee exports textures with absolute paths (I have “copy textures” set to off, since I’m managing texture exports manually) even when the paths in Blender are relative. Digging around in the source, I found this:

t_path = bpy.path.abspath(tex.texture.image.filepath)

That makes no sense- making the path absolute renders it unviewable on any but the system of the author. The abspath call should probably be removed.


#427

Сan’t remember why I did it so. Thanks. I’ll fix it.


#428

I just installed YABEE r13.1 and tried to export my model to egg format ( https://dl.dropboxusercontent.com/u/12781104/room2.blend ) and I get this error


#429

r13.1 is not works with Blender 2.65 due to changes in Blender GUI API. Try to update it, or use YABEE r12.2 for Blender 2.65


#430

I tried to use YABEE r13.1 with the 2.66 Blender version, but it did not work.

I need to export a body that I created in another program (MakeHuman) and imported by Blender. Whenever I try to export by Collada and then convert to egg by using dae2egg, a warning message appears:

and the model gets weird.

When I export using YABEE, many erros regarding the texture appear and the panda viewer shows nothing.

Does anybody know why this is happening?


#431

Which YABEE options are used?
I had no problem with MH and I can’t say what happend in this case until I see your original *.blend file and exported *.egg file. Please upload them if You can.


#432

Sorry, but what do you mean by “which YABEE options are used”?

They don’t allow me to upload these files. The *.blend one is too big and when I triend to upload the *.egg file, there was a message saying that “The extension egg is not allowed.”


#433

I could upload it by dropbox, so here they are…
there are 2 versions of *.egg, the boneco3.egg is the one that I got by dae2egg, boneco3-2.egg is the one I exported by YABEE.

dl.dropboxusercontent.com/u/101 … 0ligia.zip


#434

Hmm. The *.blend file is not the same as I get when importing model from *.mhx. Anyway try to remove or disable Texture.001 which used as alpha and then export model again.


#435

Thanks! I’ll try to do it!

But could you please send me your *.blend file so I can compare it with mine?


#436

Here my example *.blend
docs.google.com/file/d/0BxxA9bh … sp=sharing

Two things:

  1. Usually I use Low resolution “proxy”, which placed on the 5-th layer.
  2. If I used full resolution model - then I disable “Apply modifiers” in the exporter options. SubSurface modifier can’t be applied on the mesh with the Shape Keys.

#437

Thanks for your help!

It ended up that the only problem was the way I was exporting from MakeHuman, I tried to do so with Collada, end not *.mhx.


#438

Hello, I am experimenting with multipart actors. As a really simple experiment, I did this:

I opened Blender and added a single bone to the standard cube, as I understand the manual that a bone is needed to connect two parts of an actor. This bone I called “connector”. Then I exported this to an egg, but I couldn’t find the bone called connector (via opening in a text editor). I also tried it with reparenting the armature to the cube, and of course I selected both before exporting.

Anything I’ve made wrong?


#439

Did you add an armature modifier to the cube to associate one with the other? (If you’re not sure of how to do this, go to the “Properties” panel, select the “Object Modifiers” tab and select “Armature” from the “Add Modifier” drop-down menu.)


#440

No, I didn’t add the modifier - I didn’t even know that it exists :slight_smile: Now I tried it, but it still doesn’t work.

I have to learn that much, and to be honest: I hate Blender and stuff!