.x Texturing shows colour not texture


#1

I’m working on a 3d chess game in Python, and, obviously, Panda3D. I’ve modeled the pieces in Blender, and originally exported them as .x files with no embedded textures.

In Blender, I then used the standard wood algorithm to generate a wooden texture, UV unwrapped it and saved the image as a .png. I’ve only been using Panda for two days, but applying the texture seemed easy enough; loading and setting the texture.

However, after applying the texture, this happened:


, where the square next to the bishop is a CardMaker with the same texture applied. After googling and struggling with TextureStages (in vain), I tried embedding the PNG in the .x file, leading to this look:

.

Better, but still not right. After using both the embedded texture and the Panda texture, I got this:


, which was what I had been expecting all along!

Can anyone explain this behaviour?
I was not under the impression that it was necessary to embed textures in models, let alone embed and manually set them. As I mentioned earlier, I’ve only been doing this for two days, it’s very possible that I’ve made some stupid mistake, I’d appreciate any help understanding it.

Thanks for your time!
Erik


#2

Hi, welcome to the forums!

Could you attach the .x file and textures?