wxpython help

hi there…

I have removed python and wxpython and reintsalled both…im using windows xp home and python 2.4 and wxpython very latest release unicode.

… running main.py says : no module named wx found
Our program is using this to load wx: from wx import App as wxApp

Wx python was installed into panda’s site-packages DIR.
Any idea why it can’t be found ? :slight_smile:

thx mucho

I have wx-2.8-msw-unicode/wx in site-packages.
I simply created wx.pth file :

Please remember that you didn’t have to install python2.4 separately at all. Panda3D provides its own python2.4 in Panda3D-1.4.2\python\ directory.

Make sure you installed wx in panda’s sitepackages dir and not in your separate python24’s, and make sure you are running panda’s python.exe and NOT your separate python24’s python.exe.

Try running ppython, see if that makes difference. Its basically the same as python, but it makes sure it runs panda’s python and not any other.

You could add your wx install dir to the python path at runtime, so you are certain it is included:
import sys

OK everyone calm down I got it fixed LOL :wink:)

I suspected this was the problem, but the various IDE’s ive used were not working as panda’s python was not even being found… until I tried one called wingIDE which has finally worked like a charm. It turned out that the defalut install of wx was not just 'wx but wx2.6.0blah which is the ‘default’ install name it uses,- and ‘inside’ that dir of course is the ‘wx’ dir so obviously it was a simple matter of incorrect name scheme.