Hi all. I picked up a wiimote class a while back called pywiiuse. I managed to integrate it into the roaming ralph demo and make it shift the camera and stuff. Now when I try to hook it into a fps style game I’m working on, that is based on the original roaming ralph code, the wiimote violates what seems to be a memory address:
“WindowsError: exception: access violation writing 0x9C08E8D4”
I’m pretty sure it’s the wiimote because you have to press a button on the wiimote to become active and the code works fine until this point. Can anybody help me? I’m quite desperate as this is for a masters project that has to be submitted in september!!!

Sounds like you’ll need to do some debugging on the pywiiuse class. Do you have a contact for the author of that class? He/she may be able to provide more useful assistance than we can.

Have you tried running the code under the Microsoft debugger to get a stack trace when it crashes? You’ll probably need to compile the pywiiuse library yourself, or at least have the pdb’s available, in order to get anything useful out of this.

If nothing else, you might have to resort to the standard debugging tactic of determining what’s different about program B that makes it crash when program A doesn’t. This usually means starting with A and making it piecewise similar to B until it crashes, or starting with B and making it piecewise similar to A until it doesn’t crash.


I don’t know if this will help, but getting the Wiimote working in Windows is a little tricky. Not every bluetooth USB dongle works with the Wiimote on Windows… and some of them only works with one specific bluetooth stack.

wiili.com/index.php/Compatib … th_Devices

Several months ago, I did some simple tests with the Wiimote that worked flawlessly on Linux, but they never worked on Windows. I would suggest you to make some test on Linux, so you can see if the problem is your code or the Operating System. Panda3D is available on Linux and pywiiuse is “only” a python wrapper for the C library wiiuse, which also works on Linux. So, if your code is correct, you will have your project working very soon.

Thanks to you both for your replies!

I have managed to get it working in windows alright. It works fine with glovepie and johnny lee’s head tracking vr desktop. It also works fine with the roaming ralph sample when i use it to rotate the camera using the IR data. I must be doing something in my game that uses protected memory or the game itself is protecting the memory that the wiimote trys to use? I’ll try cutting chunks out of my code and see where it starts.

Thanks again.

OK, if you have the Wiimote working with Glovepie and other programs, then your problem is not the Operating System. In my case, in Windows I could only pair the Wiimote with my bluetooth dongle, but the Wiimote wasn’t detected by Glovepie (or any other program).

Good luck with that weird bug… and when you fix it, please tell us which were the problem. I’m also interested in making PC games that use the Wiimote as an optional input method.

Yeah, I had trouble at the start but I found that blue soleil worked for me. I’ll keep you posted onmy results.

Ok all is working. I have a gamepad and wiimote working at the same time. i think it was the order in which I was importing the libraries. I shuffled them around a bit and now its working fine.