what has happend to shaders!

Ok i get the new 1.4.3 cvs build but it turns out some one been reprogramming the shaders. None of the tutorials work and none of my shaders work either.

So how do we get our shaders in this version? The Bamboo seemed to work but after i uncommented shader manager it broke.

What version are you running? The CVS head?

yes CVS head.

So what was the most recent version you tried that did work?

1.4.2 release worked just find. Then i compiled CVS had because of drwr added a fix for me for make_current (which also fixed pro-rsoft looks like and maybe rest of the linux users) but the shaders are now broke. All of the shaders are. I compiled with the Cg on and the libCg.so and libCgGL.so is there.

Try setting:

notify-level-glgsg debug
notify-level-gobj debug

my last posting said:

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 2222271 bytes) in /usr/share/phpbb2/site/includes/bbcode.php on line 494

so i stuck it there

Well, I don’t know what’s going on there. The error message is coming from line 1086 in shader.cxx. But I don’t know why.

To debug it, I’m going to need you to add print-statements to cg_compile_entry_point to print out the value of ‘active’ and ‘ultimate’.

PS. The part of the code that is generating an error has not been edited for months.

If worst comes to worst, you may have to roll back the code until the error goes away, then pinpoint the day where the error began.