Visual Texture Blur

I have a texture on the walls of a building and there is a blur being applied to the textures based on the angle and distance being viewed.

Can anyone tell me where I can tweak the settings for this blurring? The blurring is killing the visual quality of the wall textures…



That’s probably mipmapping you’re seeing. You could disable mipmapping, but that will make textures flicker far away. I recommend enabling anisotropic filtering (while keeping mipmapping enabled), I’ve found that a value of 16 eliminates most of the blurring.

Thank you.

Where should I look to enable this anisotropic filtering? And what exactly is anisotropic filtering.

You can find information about it on the texture filtering page in the manual. You can also set a global configuration variable to control this for all textures - look through the list of all config variables on the manual.