Visual C++ edition to use with version 1.8.0 of Panda 3D ?

Here’s an idea. Try setting:

show-dll-error-dialog 1

in your Config.prc file. This is supposed to enable the Windows error dialog that pops up when a DLL fails to load. It should give you more useful information about what is going wrong.


I tried putting show-dll-error-dialog 1 at the end of the config.prc file. But when I run the exe no Windows error dialog pops up. In the command window - I get these lines displayed -

Previously it was something like this-

Dead End ??? :frowning: … somebody please help or else I will have to leave Panda …:frowning: This is driving me insane …

What happens if you put a call to LoadLibrary(“libpandagl.dll”); in your main program?

Are you sure you’re even loading the standard prc file in the first place? What happens if you write:

#include "configPageManager.h"

ConfigPageManager *cpMgr = = ConfigPageManager::get_global_ptr();
cerr << *cpMgr << "\n";


Using LoadLibrary(“libpandagl.dll”); causes build error - error C2664: ‘LoadLibraryW’ : cannot convert parameter 1 from ‘const char [15]’ to ‘LPCWSTR’

and writing the code -

#include “configPageManager.h”

ConfigPageManager *cpMgr = = ConfigPageManager::get_global_ptr();
cerr << *cpMgr << “\n”;

yields the following in the console window -

The LoadLibraryW error message means you incorrectly have your project settings set to build a Unicode project. You must change this to build an ANSI project instead.

Also, try:



I may have recreated your error.
I renamed my Config.prc to be something else so Panda can’t find it, and I saw the same problem.
You said you have installed on D:\ and not C:
Are you compiling and running inside of D:\ too when you run your C++ program ? I assume the samples you run are on D:\ too and so it finds Config.prc.
So maybe either Panda can’t find the Config.prc or if it is finding it, there is something wrong inside that prc file.
Are you in fact running VS2008 and not 2010, in an earlier post you said you were going to try 2010 ?

Panda allows you to set up a prc file somewhere other than D:\Panda3D-1.8.0\etc (in your case).
For example I have my own prc file named: MyConfig.prc sitting in the same folder as my executable and access it through the code in the main program.

  PandaFramework framework;
  WindowFramework *window=NULL;


Panda should find that prc file so if you still have a problem then maybe it is within the prc file.

Sorry you are having all these problems, don’t give up just yet. drwr and rdb are the main Panda Gurus and are very helpful. So like they said, be sure to start with vs2008 in release mode and have your paths set as instructed in manual (use D:\ if that is where you installed Panda). And determine if in fact your program is finding the Config.prc or if there is a bad selection in the Config.prc.

good luck

Tah and Drwr … if I were a girl I would have kissed you both … :slight_smile: … since I am not … I am sending lots of heartiest gratitude to both of you for supporting me :slight_smile: and Tah thank you for your last long supportive message … telling me not to give up.

I started with with what Drwr suggested. Changing the project from Unicode to Unicode Not Set or ANSI. Now the LoadLibrary(“libpandagl.dll”); code compiles / builds without giving any error. But still when I run the project, the same error message gets displayed in the command console. Then suddenly I came to remember
another project setting - “Use Unicode Response Files” which was by default set to yes, so I changed it to No
and then rebuilt the project again. The build process went successfully and then I hit the run button within the IDE … the command window pops up with the following message … and the first ever C++ rendering window of Panda3D pops up too …!

I will request drwr to include this in the manual so that other newbies like me don’t get sleepless nights :slight_smile:

Thanks to both of you once again for sticking with me.