Video Problem

I just updated my Xorg + Mesa + Intel drivers to latest version and Panda3D stopped working.
When I try to run the game I am developping the window appears with black color and then closes.
When running the samples, the window doesn’t close, but only shows a grey color.
Eveything were working before the update…
Other 3D games work fine.
I get no error message on the terminal.

Distro: Arch Linux
Video: VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Panda3D version: 1.6.2-3

I downgraded some stuff and now it is working.

These are the upgrades I undid:

upgraded xf86-input-evdev (2.2.5-1 -> 2.3.0-1)
upgraded xf86-input-keyboard (1.3.2-2 -> 1.4.0-1)
upgraded xf86-input-mouse (1.4.0-2 -> 1.5.0-1)
upgraded xf86-input-synaptics (1.1.3-1 -> 1.2.0-1)
upgraded xf86-video-intel (2.8.1-1 -> 2.9.1-1)
upgraded xf86-video-vesa (2.2.0-1 -> 2.2.1-1)
upgraded xorg-server ( -> 1.7.1-1)

upgraded libgl (7.5.1-2 -> 7.6-2)
upgraded intel-dri (7.5.1-2 -> 7.6-2)

Not sure if I had to downgrade Xorg for Panda3D to work, but I think the old intel-dri needs the old Xorg too.

I changed my notebook, but the problem is still there…
New GPU: VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

mobile intel graphics… (yuk)
are you sure you updated your drivers correctly and rebooted afterwards? and you say other 3d games work fine. may i ask which ones?
what does ‘glxgears’ say?

btw: running archlinux here too, but never had problems of the type you described (nvidia card)

When I had the same problems on my Intel X3100 I used info from this post. I downgraded drivers. I found them at - you have to manually browse packages from this page - you can find a few older versions of each package.

The problem isn’t directly connected with Panda3d. When I had newer drivers when I launched Ogre applications, I couldn’t see anything 3D on the screen. The same with Irrlicht and Lightfeather, but Irrlicht showed something crappy, not worth to mention.

Nemesis#13 “mobile intel graphics… (yuk)” - mobile intel graphics card isn’t so bad. Just new drivers are bad. Other games like OpenArena worked fine with acceleration when I had newer drivers.


Tested Cube here and it works well.

No problem with glxgears too.

Thanks for the link, JasonSpine. I will wait a little to see if the problem solves other way. Didn’t want to downgrade again. =/

And looks like it solved. :smiley:
I just tested my game now and it was working!
I think these updates corrected the problem:

[2009-12-22 19:31] upgraded libdrm (2.4.16-1 -> 2.4.17-2)
[2009-12-22 19:31] upgraded libgl (7.6-2 -> 7.6.1-1)
[2009-12-22 19:31] upgraded intel-dri (7.6-2 -> 7.6.1-1)
[2009-12-22 19:31] upgraded mesa (7.6-2 -> 7.6.1-1)