Using Python 2.6.2 with Panda3D 1.6.2


#1

I didn’t build Panda3D 1.6.2 from source just yet, I want to understand the python mechanics first before I can fully plot out my development pattern.

I noticed it was using Python 2.4, which is acceptable but using Python 2.6.2 before I begin development would be ideal for minimal backtracking.

Do I have to do anything special to use Python 2.6.2? Or can I just reroute panda and my cmd prompt to 2.6.2 and expect no problems?


#2

You have to use the version of Python that Panda was compiled against. Since the version for download here has been compiled against Python 2.5 (not 2.4), it means you have to use it with Python 2.5, unless you want to get the source and build it yourself.

If you build it yourself, you can tell it to use any version of Python you’ve got.

David


#3

Okay thanks, I think I’ll rebuild it for 2.6, assuming 2.6’s backwards compatibility is enough from keeping anything from breaking.


#4

Just an FYI: The upcoming 1.7.0 release will be built against Python 2.6.