Using pylint with Panda3D

We are looking at implementing pylint with our Panda3D project. However they don’t seem to play nicely together.

Is there anything I can set in the pylint rcfile to get it going. It tends to get into an infinite loop when some Panda3D methods are called.

Has anyone been able to successfully use pylint along side Panda projects?

I’ve never tried it before. Really? It gets caught in a loop? Weird, we’re not doing anything that exotic. I wonder what pylint is doing, it sounds more like a runtime checker than the syntax checker that is C lint.


I remember running into the same problem. Sadly I have not used it in a while. The fix I used was limiting how deep it would recursive scan to 2-3 levels.

I’m sorry I couldn’t be more useful.

Limiting the recursion like so for each file? or can you set it globally somewhere?

import sys


I have the same problem. It worked well with python2.5, but since python 2.6, I have a maximum recursion depth in the astng module :frowning: .