Urgent Help

I am working on a commercial game project, and I just recently ported my code over to Panda3D.

Everything has been going great, until I realized that the .egg exporter for Blender did not support Blender 2.5. This is a huge problem, as all my models are saved using Blender 2.5, and it would be way to much work to remake them all.

Is there any way I can get around this?

You can export to .dae (COLLADA), and convert the resulting file to egg using the dae2egg converter.

I tried that, but the Collada exporter does not work correctly.

I did finaly get the model in to Blender 2.4. I used the Append Or Link function, which will open newer Blender files.

I have a new problem though. I rigged and animated the legs of my model. I exported this animation as ‘walk’, and a still frame of the model in a resting position as ‘rest’. I loaded this into Panda and it worked like a charm. My animation showed up perfectly fine.

I then rigged the upper body. I did not animate it though; I just moved it into a rest position. The whole model uses one armature.

The model exported to .egg perfectly fine, but when I open it when pview, it says “No animation” and does not show anything. I then tried exporting the model without any animations. When I load it with pview I don’t get any errors, but I don’t see the mesh.

Here is the .blend file: mediafire.com/?0czmazcqq0c6kxx

If anyone could tell me why this it not working I would be eternally grateful.




If I delete the upper half of the armature it exports correctly.

Any ideas?

I hear they’re doing away with Chicken. Not sure if that’s true, but Blender 2.5 has a very nice dae exporter and dae2egg works great.

Are you using the latest buildbot install or the old stable?

[url]dae2egg Assertion Failed]

Is this topic relevant to you?
I was having issues with blender 2.5, then I upgraded to the latest dae2egg, now everything works great.

I found the problem. It seems to be a bug in the exporter.

When you have two different objects weight painted to one bone it does not export correctly.